《ACM程序设计》书中题目W

Description

Tom’s Meadow
Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

Not all squares are covered with grass.
No two mowed squares are adjacent.
Two squares are adjacent if they share an edge. Here comes the problem: Is Tom’s meadow beautiful now?

Input
The input contains multiple test cases!

Each test case starts with a line containing two integers N, M (1 <= N, M <= 10) separated by a space. There follows the description of Tom’s Meadow. There’re N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output
One line for each test case.

Output “Yes” (without quotations) if the meadow is beautiful, otherwise “No”(without quotations).

Sample Input
2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output
Yes
No
No

统计0的个数以及搜索是否存在纵向和横向两个方向之一存在连续0的情况,用二位map进行搜索。

代码如下:

#include<bits/stdc++.h>
using namespace std;
const int MAX = 12;
int main()
{
    int map[MAX][MAX];
    int i,j,n,m,flag1,flag2;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0||m==0)
        {
            break;
        }
        for(i=0;i<MAX;++i)
        {
            for(j=0;j<MAX;++j)
            {
                map[i][j]=1;
            }
        }
        flag1=0;
        flag2=1;
        for(i=1;i<=n;++i)
        {
            for(j=1;j<=m;++j)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j] == 0)
                {
                    flag1=1;
                }
            }
        }
        for(i=1;i<=n&&flag2;++i)
        {
            for(j=1;j<=m&&flag2;++j)
            {
                if((map[i-1][j]==0||map[i+1][j]==0||map[i][j+1]==0||map[i][j-1]==0)&&map[i][j]==0)
                {
                    flag2=0;

                }
            }
        }
        if(flag1&&flag2)
        {
            printf("Yes\n");
        } 
        else
        {
            printf("No\n");
        }     
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值