ZOJ2850 Beautiful Meadow java

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2850

                                  Beautiful Meadow

                                                       

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No

题意:

Tom有一片花园,初始所有方块的覆盖草,你需要除草使它成为最美花园,有2个条件。

1:不能所有的方块都覆盖草。

2:不能两个相邻的方块覆盖草。

数字0意味着草地是修剪过的,数字1意味着是草覆盖的。

思路:

首先判断所有方块是不是覆盖草,如果有修建的,就判断是否相邻两个是修建过的,如果是则返回NO,否则YES。

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int n=sc.nextInt();
			int m=sc.nextInt();
			if(n==0&&m==0){
				break;
			}
			boolean flag=false;
			int a[][]=new int[n][m];
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){
					a[i][j]=sc.nextInt();
				}
			}
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){	//判断是否修剪过,修建过就是true
					if(a[i][j]==0){
						flag=true;
						break;
					}
				}
				if(flag==true)break;
			}
			for(int i=0;i<m-1&&flag==true;i++){	//判断有没有相邻的修建的方块
				if(a[0][i]==0&&a[0][i+1]==0){
					flag=false;
				}
			}
			for(int i=0;i<n-1&&flag==true;i++){ //判断有没有相邻的修建的方块
				if(a[i][0]==0&&a[i+1][0]==0){
					flag=false;
				}
			}
			for(int i=1;i<n&&flag==true;i++){
				for(int j=1;j<m;j++){
					if((a[i][j]==0&&a[i-1][j]==0)||(a[i][j]==0&&a[i][j-1]==0)){ //判断有没有相邻的修建的方块
						flag=false;
						break;
					}
				}
			}
			if(flag==true){
				System.out.println("Yes");
			}
			else{
				System.out.println("No");
			}
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值