PAT 1042 Shuffling Machine [模拟] [特殊点求余的处理]

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 

我的代码:

#include<stdio.h> 
int main()
{
	char rc[60];
	int i,times,a[60],ri[60],count=1;
	scanf("%d",&times);
	for(i=1;i<=54;i++)
	    scanf("%d",&a[i]);
    //卡片的初始化肯定得先存起来,但是54个太多啦不可能开数组逐一录入,我想的笨蛋方法是将数字和字符分开,再用if语句分类存取。 
    for(i=1;i<=54;i++,count++)
    {
    	if(count>13) count = 1;
    	if(i<=13) {rc[i] = 'S';ri[i] = count;}
    	else if(i<=26) {rc[i] = 'H';ri[i] = count;}
    	else if(i<=39) {rc[i] = 'C';ri[i] = count;}
    	else if(i<=52) {rc[i] = 'D';ri[i] = count;}
    	else {rc[i] = 'J';ri[i] = count;}
    }
    char newC[60],newI[60];
    while(times--) //重复次数
    {
    	for(i=1;i<=54;i++)
    	{
    	    //开一个新的数组来存取重复后的新排列顺序
	    	newC[a[i]] = rc[i]; //字符部分
	    	//printf("%c%c\n",rc[i],newC[a[i]]);
	    	newI[a[i]] = ri[i]; //整数部分
	    } 
	    //存取这一次的更新结果以便下一次的更新。
	    /*这里一开始我犯了两个错误:①我写的是rc[i] = newC[a[i]],这让存取旧结果变得没有任何意义。
	    ②我将存取代码并在了上面的循环里,自以为免去了繁琐,但那时newC[]数组还没有赋值完毕,如此一来只会让部分rc[]的值变得奇怪。*/ 
	    for(i=1;i<=54;i++)
        {
        	rc[i] = newC[i];
        	ri[i] = newI[i];
        }
	    /*for(i=1;i<=54;i++)
	        printf("%c%d ",newC[i],newI[i]);
     printf("\n");*/
    }
    for(i=1;i<=54;i++)
    {
    	printf("%c%d",newC[i],newI[i]);
    	if(i!=54) printf(" ");
    }
}

优化后的代码:

#include<stdio.h>
int main()
{
	char s[5] = {'S','H','C','D','J'};
	int i,times,old[60],neww[60],a[60];
	scanf("%d",&times);
	//我存取初始卡牌顺序十分复杂,而直接存取1-54的数字使得区分卡牌更为直接简洁,也减少了处理字符的麻烦
	for(i=1;i<=54;i++)
	{
		old[i] = i;
		scanf("%d",&a[i]);
	}	
	while(times--)
	{
		for(i=1;i<=54;i++)
    	    neww[a[i]] = old[i];
        for(i=1;i<=54;i++)
            old[i] = neww[i]; 
	}    
    for(i=1;i<=54;i++)
    {
    	neww[i]--; //否则在输出整数部分时,会碰到neww[i]=13,而13%13=0的问题
        //特殊点求余的处理,先-1,求余后再+1
    	printf("%c%d",s[neww[i]/13],neww[i]%13+1);
    	if(i!=54) printf(" ");
    }    
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
A shuffling machine in C++ can be implemented using an array to represent the deck of cards and using the random number generator to shuffle the cards. Here is a sample code for a shuffling machine: ``` #include <iostream> #include <cstdlib> #include <ctime> using namespace std; const int NUM_CARDS = 52; class ShufflingMachine { private: int deck[NUM_CARDS]; int position; public: ShufflingMachine() { for (int i = 0; i < NUM_CARDS; i++) { deck[i] = i; } position = 0; } void shuffle() { srand(time(NULL)); for (int i = 0; i < NUM_CARDS; i++) { int j = rand() % NUM_CARDS; swap(deck[i], deck[j]); } position = 0; } int dealCard() { if (position >= NUM_CARDS) { shuffle(); } return deck[position++]; } }; int main() { ShufflingMachine shuffler; shuffler.shuffle(); for (int i = 0; i < NUM_CARDS; i++) { cout << shuffler.dealCard() << " "; } cout << endl; return 0; } ``` In this code, the `ShufflingMachine` class represents the shuffling machine. The `deck` array stores the deck of cards, and the `position` variable keeps track of the current position in the deck. The `shuffle` method shuffles the deck by randomly swapping cards. It uses the `srand` function to seed the random number generator with the current time, and the `rand` function to generate random indices for swapping cards. The `dealCard` method deals the next card from the deck. If the deck has been exhausted, it calls the `shuffle` method to shuffle the cards again. In the `main` function, we create a `ShufflingMachine` object and shuffle the cards. Then we deal all the cards and print them out.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值