PAT 1141 PAT Ranking of Institutions [map STL] [sort排序] [string类型的大小写转换]

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

--------------------------------------这是题目和解题的分割线--------------------------------------

题目意思很简单啦,就是要分类排序,这时候肯定是要用上结构体的啦~又因为还要统计tws,所以得用map操作一下。一开始结构体一股脑把每个人的ID都存了进去,一共N个,写到排序的时候发现太多重复才反应过来,有最后输出的那几项就足够啦。

照例说一说这道题的额外收获——关于大小写字母的转换

char字符数组的大小写转换,可以用tolower()和toupper()函数,头文件是#include<ctype.h>

string类型的大小写转换,需要用transform(str.begin(),str.end(),str.begin(),::tolower); 和transform(str.begin(),str.end(),str.begin(),::toupper);  头文件是#include<algorithm>

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<map>

using namespace std;

struct node
{
	string name; //学校 
	int tws; //总分 
	int cnt; //每个学校的人数 
}st[100005];
 
bool cmp(node a,node b)
{
	if(a.tws!=b.tws)
		return a.tws>b.tws;
	else if(a.cnt!=b.cnt)
		return a.cnt<b.cnt;
	else
		return a.name<b.name;
}

int main()
{
	int n,i,rank = 1;
	//sc算分数,cnt存人数 
	map<string,float> sc,cnt;
	cin>>n;
	for(i=0;i<n;i++)
	{
		string name,id;
		int score;
		cin>>id>>score>>name;
		//先转换为小写字母 
		transform(name.begin(),name.end(),name.begin(),::tolower);
		//如果map数组里还没有这个学校,加入结构体数组(去重过程) 
		if(sc.find(name)==sc.end())
			st[sc.size()].name = name;
		cnt[name]++; //学校人数
		//注意之前的map数组用浮点数,最后总和再进行取整 
		if(id[0]=='A')
			sc[name] += score*1.0;
		else if(id[0]=='B')
			sc[name] += score/1.5;
		else
			sc[name] += score*1.5;	
	}
	cout<<sc.size()<<endl;
	for(i=0;i<sc.size();i++)
	{
		//tws进行取整 
		st[i].tws = int(sc[st[i].name]);
		st[i].cnt = cnt[st[i].name];
	}
	sort(st,st+sc.size(),cmp);
	for(i=0;i<sc.size();i++)
	{
		//如果和上一个分数不同,排名为i+1,否则不变 
		if(i!=0&&st[i].tws!=st[i-1].tws) rank = i+1;
		cout<<rank<<" "<<st[i].name<<" "<<st[i].tws<<" "<<st[i].cnt<<endl;	
	}		
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值