PAT 1052 Linked List Sorting [静态链表]

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer keyand a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

-----------------------------------这是题目和解题的分割线-----------------------------------

这三道题套路是一模一样的,PAT 1097 Deduplication on a Linked List / PAT 1074 Reversing Linked List

注意点:存在无效结点,当有效结点为0的时候,输出0 -1。

#include<cstdio>
#include<algorithm>
#define maxN 100010

using namespace std;

struct node
{
	int address;
	int data;
	int next;
	int order;
}list[maxN];

bool cmp1(node a,node b)
{
	return a.order<b.order;
}

bool cmp2(node a,node b)
{
	return a.data<b.data;
}

int main()
{
	int begin,n,i;
	scanf("%d%d",&n,&begin);
	int address;
	for(i=0;i<maxN;i++)
		list[i].order = maxN;
	for(i=0;i<n;i++)
	{
		scanf("%d",&address);
		scanf("%d%d",&list[address].data,&list[address].next);
		list[address].address = address;
	}
	int order = 0;
	while(begin!=-1)
	{
		list[begin].order = order++; //标志为有效结点并记录个数 
		begin = list[begin].next;
	}
	//全部排序,将无效结点筛到数组末端 
	sort(list,list+maxN,cmp1);
	//按照数值递增排序 
	sort(list,list+order,cmp2);
	//特殊情况特殊处理 
	if(order==0) {printf("0 -1\n");return 0;}
	else printf("%d %05d\n",order,list[0].address);
	for(i=0;i<order-1;i++)
		printf("%05d %d %05d\n",list[i].address,list[i].data,list[i+1].address);
	printf("%05d %d -1\n",list[order-1].address,list[order-1].data);
}

这个也换种方法试试

#include<cstdio>
#include<algorithm>

using namespace std;

struct node
{
	int address;
	int data;
	int next;
}list[100010],print[100010];

bool cmp(node a,node b)
{
	return a.data<b.data;
}

int main()
{
	int begin,n,i;
	scanf("%d%d",&n,&begin);
	for(i=0;i<n;i++)
	{
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		list[a].address = a;
		list[a].data = b;
		list[a].next = c;
	}
	int cnt = 0;
	while(begin!=-1)
	{
		print[cnt++] = list[begin];
		begin = list[begin].next;
	}
	sort(print,print+cnt,cmp);
	//有效结点为0时(注意是cnt=0不是n=0),特殊处理 
	if(cnt==0)
	{
		printf("0 -1\n");
		return 0;
	}
	printf("%d %05d\n",cnt,print[0].address);
	for(i=0;i<cnt;i++)
	{
		printf("%05d %d",print[i].address,print[i].data);
		if(i==cnt-1) printf(" -1\n");
		else printf(" %05d\n",print[i+1].address);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值