PAT 1005 Spell It Right [字符串处理]

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

我的代码: 

//非递归
 
#include<stdio.h>
#include<string.h>

int main()
{
	char num[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	char s[100];
	scanf("%s",s);
	int i,sum = 0,t[100],count = 0;
	for(i=0;i<strlen(s);i++)
		sum += s[i]-'0';
	//特殊情况千万不要漏!(如果输入为0,就进不去下面的while循环 
	if(sum==0)
	{
		printf("zero");
		return 0;
	}
	while(sum!=0)
	{
		t[count++] = sum%10;
 		sum /= 10;
	}
	//逆序输出 
	for(i=count-1;i>=0;i--)
	{
		printf("%s",num[t[i]]);
		if(i) printf(" ");
	}       
}

//递归
#include<stdio.h>
#include<string.h>

char num[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};

//递归不需要考虑zero的特殊情况,也不需要逆序输出(栈的思想)
void f(int n)
{
	if(n/10==0)
	{
		printf("%s",num[n%10]);
		return;
	}
	f(n/10);
	printf(" %s",num[n%10]);
} 

int main()
{
	char s[100];
	scanf("%s",s);
	int i,sum = 0,t[100],count = 0;
	for(i=0;i<strlen(s);i++)
		sum += s[i]-'0';  
	f(sum);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值