PAT 1084 Broken Keyboard [大小写的判断和转换] [string的find函数] [hash]

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

-------------------------------------这是题目和解题的分割线-------------------------------------

头文件#include<ctype.h>下有好多个好用的函数~

isalpha()用来判断一个字符是否为字母

isalnum()用来判断一个字符是否为数字或者字母

islower()用来判断一个字符是否为小写字母

isupper()用来判断一个字符是否为大写字母

isdigit()用来判断一个字符是否为数字

toupper()用来转换成大写字母

tolower()用来转换成小写字母

看柳神代码也发现一个超好用的函数 ,string字符串的find函数

string中find()返回值是字母在母串中的位置(下标记录),如果没有找到,那么会返回一个特别的标记string::npos

 

我的代码:

#include<string>
#include<iostream>
#include<cctype>

using namespace std;

int main()
{
	string s1,s2,tmp = "",print = "";
	bool test[1000] = {};
	int i,j;
	cin>>s1>>s2;
	for(i=0,j=0;i<s1.length();)
	{
		if(isalpha(s1[i])) s1[i] = toupper(s1[i]);
		if(isalpha(s2[j])) s2[j] = toupper(s2[j]);
		if(s1[i]!=s2[j])
		{
			//cout<<i<<" "<<j<<" "<<s1[i]<<endl;
			tmp += s1[i];
			i++;
		}
		else
		{i++;j++;}
	}
	for(i=0;i<tmp.length();i++)
	{
		if(!test[tmp[i]]) 
		{
			print += tmp[i];
			test[tmp[i]] = true;
		}	
		else continue;
	}
	cout<<print<<endl;
	return 0;
}

参考柳神的代码:

#include<iostream>
#include<string>

using namespace std;

int main()
{
	string s1,s2,print;
	cin>>s1>>s2;
	for(int i=0;i<s1.length();i++)
	{ 
		if(s2.find(s1[i])==string::npos&&print.find(toupper(s1[i]))==string::npos)
			print += toupper(s1[i]);
	}
	cout<<print;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值