PAT 1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-linerecords that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

----------------------------------这是题目和解题的分割线----------------------------------

这篇题目好长信息量好多,我偷懒直接看的书上思路了= = 

#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

struct node
{
	int mo,dd,hh,mm;
	char name[30];
	int state;
}bill[1054];

//通话记录必须是on和off挨一块儿的才算,排序后方便统计 
bool cmp(node a,node b)
{
	if(strcmp(a.name,b.name)!=0) return strcmp(a.name,b.name)<0;
	else if(a.mo!=b.mo) return a.mo<b.mo;
	else if(a.dd!=b.dd) return a.dd<b.dd;
	else if(a.hh!=b.hh) return a.hh<b.hh;
	return a.mm<b.mm;
}

int main()
{
	int cost[24],i,j,n;
	for(i=0;i<24;i++)
		scanf("%d",&cost[i]);
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		char s[10];
		scanf("%s%d:%d:%d:%d%s",bill[i].name,&bill[i].mo,&bill[i].dd,&bill[i].hh,&bill[i].mm,s);
		if(strcmp(s,"on-line")==0) bill[i].state = 1;
		else bill[i].state = 0;
	}
	sort(bill,bill+n,cmp);
	//on和off为配对的两条记录,next是下一个用户 
	int on = 0,off,next;
	while(on<n)
	{
		next = on; //从当前位置开始寻找下一个用户 
		int flag = 0; //有无有效通话记录的标志 
		//①还在输入的范围内搜索 ②on和next的名字相同确保是同一个用户 
		while(next<n&&strcmp(bill[on].name,bill[next].name)==0)
		{
			//这里无需关注有几条记录,只判断有无,所以判断里一定要有flag 
			if(flag==0&&bill[next].state==1)
				flag = 1;
			else if(flag==1&&bill[next].state==0)
				flag = 2;
			next++;
		}
		//如果没有找到有效记录,跳过本轮,并将on置成下一个用户 
		if(flag!=2)
		{
			on = next;
			continue;
		}
		printf("%s %02d\n",bill[on].name,bill[on].mo);
		int moneyA = 0;
		//on~next-1是当前用户的全部通话记录 
		while(on<next)
		{
			//找到配对的即连续的挨在一块儿的on和off 
			while(on!=next-1&&!(bill[on].state==1&&bill[on+1].state==0))
				on++;
			off = on+1;
			//说明while循环是因为on=next-1而终止,即没有第二条或者更多的有效记录了
			//至少有一条,因为前面已经进行过有无判断了 
			if(off==next)
			{
				on = next;
				break;
			}
			printf("%02d:%02d:%02d ",bill[on].dd,bill[on].hh,bill[on].mm);
			printf("%02d:%02d:%02d ",bill[off].dd,bill[off].hh,bill[off].mm);
			int time = 0,money = 0;
			//不断将起始时间加1,来统计时间和金钱。 
			while(bill[on].dd<bill[off].dd||bill[on].hh<bill[off].hh||bill[on].mm<bill[off].mm)
			{
				time++;
				bill[on].mm++;
				money += cost[bill[on].hh];
				if(bill[on].mm==60) //一小时60分钟 
				{
					bill[on].mm = 0;
					bill[on].hh++;
				}
				if(bill[on].hh==24) //一天24小时 
				{
					bill[on].hh = 0;
					bill[on].dd++;
				}
			}
			printf("%d $%.2f\n",time,money/100.0);	
			moneyA += money;
			on = off+1;	//别忘了on的值要改变,以便进入第二条或者更多的查找过程	
		}
		printf("Total amount: $%.2f\n",moneyA/100.0);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值