PAT 1094 The Largest Generation [DFS] [BFS] [树的遍历] [每层的结点个数]

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

------------------------------------这是题目和解题的分割线------------------------------------

求每层的人数,输出最大值。BFS和DFS都行,对应的是层次遍历和先序遍历,关键在层数上。

//BFS

#include<cstdio>
#include<vector>
#include<queue>

using namespace std;

struct node
{
	int layer; //层次遍历,不进行递归不能传参数,还是开个结构体记一下层数吧 
	vector<int> child;
}tree[110];

int n,m,level[110] = {}; //开个数组记录层数 

//层次遍历 
void layerOrder(int index)
{
	queue<int> q;
	q.push(index);
	while(!q.empty())
	{
		int top = q.front();	
		//pop之前,把这个结点加进该层	
		level[tree[top].layer]++;
		q.pop();
		for(int i=0;i<tree[top].child.size();i++)
		{			
			int child = tree[top].child[i];
			tree[child].layer = tree[top].layer+1; //遍历子结点的时候,层数+1 
			q.push(child);
		}	
	}
}

int main()
{
	int i,x,xx,id,j;
	scanf("%d%d",&n,&m);
	for(i=0;i<m;i++)
	{
		scanf("%d%d",&id,&x);
		for(j=0;j<x;j++)
		{
			scanf("%d",&xx);
			tree[id].child.push_back(xx);
		}		
	}
	layerOrder(1); //root结点是1 
	int maxN = 0,t = 0;
	for(i=0;i<110;i++) //数据不多,可以全部找一遍 
	{
		if(level[i]>maxN) 
		{
			t = i; //记录层数和人数 
			maxN = level[i];
		}		
	}
	//层数从0算起,输出要求从1,所以+1 
	printf("%d %d\n",maxN,t+1);
	return 0;
}
//DFS

#include<cstdio>
#include<vector>

using namespace std;

vector<int> tree[100010];
int lay[100010] = {};

void dfs(int index,int layer)
{
	lay[layer]++;
	if(tree[index].size()==0)
		return;
	for(int i=0;i<tree[index].size();i++)
		dfs(tree[index][i],layer+1);
}

int main()
{
	int n,m,i,j,id,k,x;
	scanf("%d%d",&n,&m);
	for(i=0;i<m;i++)
	{
		scanf("%d%d",&id,&k);
		for(j=0;j<k;j++)
		{
			scanf("%d",&x);
			tree[id].push_back(x);
		}
	}
	dfs(1,1);
	int maxL = 0,level;
        //一个结点一层也就n层,所以在1-n内遍历就好
	for(i=1;i<=n;i++)
	{
		if(lay[i]>maxL)
		{
			maxL = lay[i];
			level = i;
		}	
	}
	printf("%d %d\n",maxL,level);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值