PAT 1089 Insert or Merge

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

--------------------------------------这是题目和解题的分割线--------------------------------------

考察归并排序和插入排序【排序算法】冒泡排序|选择排序|插入排序|sort函数|归并排序|快速排序 

我的思路比较简单粗暴了,算法复杂度是O(N2),不太行,但好在这道题对时间要求不高。

等过两天回学校看看别人O(N)是怎么写出来的,如果我还记得的话。

#include<cstdio>

int out[110],cnt = 0;

//插入排序 
int ifInsert(int a[],int n)
{
	int i,j,flag = 0;
	for(i=1;i<n;i++)
	{
		int tmp = a[i];
		for(j=i;j>0&&a[j-1]>tmp;j--)
			a[j] = a[j-1];
		a[j] = tmp;
		if(flag) //输出序列 
		{
			printf("Insertion Sort\n");
			for(j=0;j<n;j++)
			{
				printf("%d",a[j]);
				if(j!=n-1) printf(" ");
			}
			return 1;
		}
		for(j=0;j<n;j++)
			if(out[j]!=a[j]) break;
		if(j==n) flag = 1; //如果此时的序列和题目给出的完全一致,在下一次循环中输出 
	}
	return 0; //返回值用来判断是否要归并排序 
}

void mSort(int a[],int temp[],int left,int right,int rightEnd)
{
	int leftEnd = right-1,cnt = left,i;
	while(left<=leftEnd&&right<=rightEnd)
	{
		if(a[left]<=a[right]) temp[cnt++] = a[left++];
		else temp[cnt++] = a[right++];
	}
	while(left<=leftEnd)
		temp[cnt++] = a[left++];
	while(right<=rightEnd)
		temp[cnt++] = a[right++];
	for(i=0;i<cnt;i++,rightEnd--)
		a[rightEnd] = temp[rightEnd];
}

void merge(int a[],int tmp[],int len,int n)
{
	int i,j;
	for(i=0;i<n-len*2;i=i+2*len)
		mSort(a,tmp,i,i+len,i+2*len-1);
	if(i+len<n)
		mSort(a,tmp,i,i+len,n-1);
	else
	{
		for(j=i;j<n;j++)
			tmp[j] = a[j];
	}
}

void ifMerge(int a[],int n)
{
	int len = 1,tmp[n],flag = 0,i;
	while(len<n)
	{
		merge(a,tmp,len,n);
		len *= 2;
		if(flag)
		{
			printf("Merge Sort\n");
			for(i=0;i<n;i++)
			{
				printf("%d",tmp[i]);
				if(i!=n-1) printf(" ");
			}
			return;
		}
		for(i=0;i<n;i++)
			if(out[i]!=tmp[i]) break;
		if(i==n) flag = 1; //如果完全一致,在下一次循环中输出序列 
	}
}

int main()
{
	int a[110],b[110],i,temp[110],n;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		b[i] = a[i]; //经过插入排序后,a数组已经是有序的,用b数组来进行归并排序 
	}	
	for(i=0;i<n;i++)
		scanf("%d",&out[i]);		
	int x = ifInsert(a,n);
	if(!x) ifMerge(b,n);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值