PAT 1003 Emergency [dijkstra] [最短路径条数]

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

-------------------------------------这是题目和解题的分割线-------------------------------------

 Dijkstra算法求解最短路径问题。

#include<cstdio>
#include<algorithm>
 
const int inf = 0x3fffffff;
const int maxN = 540;

using namespace std;

//dis记录所有结点到达指定点的最短距离 
int G[maxN][maxN],vis[maxN] = {},dis[maxN];
//num记录所有结点到达指定点的路径条数
//teams记录所有结点到达指定点的营救队数量
//value记录所有结点拥有的营救队数量 
int num[maxN] = {},teams[maxN] = {},value[maxN];
int n,m,start,en;

void dijkstra(int st)
{
	//想要赋值0和-1以外的数,看准fill函数~ 
	fill(dis,dis+maxN,inf);
	dis[st] = 0;  
	num[st] = 1;
	teams[st] = value[st];
	//以上三个,起点的值都要进行初始化 
	int i,j;
	for(i=0;i<n;i++)
	{
		//在未访问过的点中,寻找距离指定点最近的 
		int minI = -1,minN = inf;
		for(j=0;j<n;j++)
		{
			if(!vis[j]&&dis[j]<minN)
			{
				minI = j;
				minN = dis[j];  
			}
		}
		vis[minI] = 1; //标记为已访问
		//如果新加入的结点让最短距离发生了改变 
		for(j=0;j<n;j++)
		{
			//1.没访问过 2.存在边 3.最短距离可更新 
			if(!vis[j]&&G[minI][j]!=inf&&dis[minI]+G[minI][j]<dis[j])
			{
				dis[j] = dis[minI]+G[minI][j];
				num[j] = num[minI]; //该结点的num等于前驱结点的num 
				teams[j] = teams[minI]+value[j];
			}
			//如果距离相等 
			else if(dis[minI]+G[minI][j]==dis[j])
			{
				num[j] += num[minI]; //条数增加 
				if(teams[minI]+value[j]>teams[j]) //如果营救队数量更多 
					teams[j] = teams[minI]+value[j]; //才更新 
			}
		}
	}
}

int main()
{
	int i;
	scanf("%d%d%d%d",&n,&m,&start,&en);
	fill(G[0],G[0]+maxN*maxN,inf); //二维数组的fill写法 
	for(i=0;i<n;i++)
		scanf("%d",&value[i]);
	for(i=0;i<m;i++)
	{
		int a,b,x;
		scanf("%d%d%d",&a,&b,&x);
		G[a][b] = x;
		G[b][a] = x; //无向边!!! 
	}
	dijkstra(start); 
	printf("%d %d\n",num[en],teams[en]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值