PAT 1015 Reversible Primes [素数判断] [数字翻转] [进制转换]

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or Noif not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

-------------------------------------这是题目和解题的分割线-----------------------------------------

#include<cstdio>
#include<cmath>

int isPrime(int x)
{
	if(x<2) return 0; //注意:1不是素数 
	int sqr = (int)sqrt(x*1.0);
 	//不用担心素数2进入被误判,sqr = 1,它压根儿进不来
	for(int i=2;i<=sqr;i++) 
		if(x%i==0) return 0;
	return 1;
}

int main()
{
	int n,r,tmp[100];
	while(1)
	{
		//数字和进制分开输入,以便根据n的值随时中断循环 
		scanf("%d",&n);
		if(n<0) break;
		scanf("%d",&r);
		//如果还没翻转就不是素数了,肯定不符合条件,continue 
		if(!isPrime(n))
		{
			printf("No\n");
			continue;
		}
		int num = 0,i,sum = 0;
		//进制转换保存到数组,不过非递归实现数组中是倒序 
		while(n)
		{
			tmp[num++] = n%r;
			n = n/r;
		}
		//倒序正好不用翻转了,直接转换为十进制 
		for(i=0;i<num;i++)
			sum += tmp[i]*pow(r,num-1-i);
		if(!isPrime(sum))
			printf("No\n");
		else printf("Yes\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值