POJ 3278-- Catch That Cow

题目:

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 76114 Accepted: 24036

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:
FJ要抓牛,牛在k位置,FJ在n位置,假设牛是在原地不动的,FJ假设在X点,可以向X+1走一步,或者X-1走一步,或者2*X走一步,问最短路。

思路:
如果牛在FJ后面,那么FJ只能一步一步向后走,否则宽搜。

实现:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
using namespace std;

const int maxn = 100005;

struct node {
    int nn, step;
};
int _map[maxn];//记录到某一点的最短步数

int bfs (int n, int k) {
    queue <node>q;
    node head;
    head.nn = n;
    head.step = 0;
    _map[head.nn] = 0;
    q.push(head);
    while(!q.empty()) {
        node en;
        node start = q.front();
        if (start.nn == k)
            return _map[k];
        q.pop();
        for (int i = 0; i < 3; i++) {
            if (i == 0 && start.nn + 1 <= maxn) {
                en.nn = start.nn + 1;
                en.step = start.step + 1;
            }
            else if (i == 1 && start.nn - 1 >= 0) {
                en.nn = start.nn - 1;
                en.step = start.step + 1;
            }
            else if (i == 2 && 2 * start.nn <= maxn) {
                en.nn = start.nn * 2;
                en.step = start.step + 1;
            }
            if (_map[en.nn] > start.step + 1) {
                _map[en.nn] = start.step + 1;
                q.push(en);
            }
        }

    }

return -1;
}

int main() {
    int n, k;
    while (scanf("%d%d", &n, &k) != EOF) {
        for (int i = 0; i <= maxn; i++) {
            _map[i] = maxn + 5;
        }
        if (n >= k)
            printf("%d\n", n - k);
        else
            printf("%d\n", bfs(n, k));
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值