hdu 4268 Alice and Bob(贪心)

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4751    Accepted Submission(s): 1487


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
  
  
1 2
 

Source

题意:给出Alice和Bob的卡牌的长度和宽度,问Alice可以覆盖多少张Bob的卡牌(一张只能使用一次),覆盖是长度和宽度都大于等于Bob的卡牌的长宽


分析:暴力的话O(n^2)会超时的,可以先将x按降序排(后面排的x一定是小于前面的x),如果x相等则按y的降序排。这样只需要比较y就可以了。

然后用跑一次,如果是Alice的卡,就将y加入multiset里,否则则查询multiset里是否有比Bob的y大的。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
#define MAX_N 100005
using namespace std;
struct node
{
    int x,y;
    int id;
}a[2*MAX_N];
bool cmp(node a,node b)
{
    if(a.x==b.x&&a.y==b.y)
        return a.id<b.id;
    if(a.x!=b.x)
        return a.x>b.x;
    return a.y>b.y;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].id=1;
        }
        for(int i=n+1;i<=2*n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].id=2;
        }
        sort(a+1,a+1+2*n,cmp);
        multiset<int> s;
        int cnt=0;
        for(int i=1;i<=2*n;i++)
        {
            if(a[i].id==1)
            {
                s.insert(a[i].y);
            }
            else
            {
                multiset<int> ::iterator it=s.lower_bound(a[i].y);
                if(it==s.end())
                    continue;
                else
                {
                    cnt++;
                    s.erase(it);
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值