Alice And Bob Hdu--复杂的贪心

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1545    Accepted Submission(s): 570


Problem Description

 

Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 


 

Input

 

The first line of the input is a number T (T <= 40) which means the number of test cases.  
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 


 

Output

 

For each test case, output an answer using one line which contains just one number.
 


 

Sample Input

 

  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 


 

Sample Output

 

  
  
1 2
 


 

Source

 

 


 

Recommend

 

liuyiding


 

题意就是定义了一个cover,表示Alice的卡片长宽都不小于Bob的卡片长宽,求最大cover数,就用贪心来做。

这里用上了STL库里的multiset函数,先将他们的卡片放在一起以高从小到大排序,高相等了以长从小大大排序,都相等了就先排Bob的卡片。

用lower_bound(w)直接找到在set大于等于w的最小值,就可以保证贪心算法的正确性了。

代码如下:

#include<cstdio>
#include<set>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 100001
int n;
struct node
{
	int h,w;
	int belong;
}a[2*N];
multiset<int>bob;
bool cmp(node a,node b)
{
	if(a.h!=b.h)return a.h<b.h;
	else if(a.w!=b.w)return a.w<b.w;
	else return a.belong>b.belong;//保证set里先有元素,再比较
}
int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++){
			scanf("%d %d",&a[i].h,&a[i].w);
		a[i].belong = 0;
		}
		for(i=n;i<2*n;i++){
			scanf("%d %d",&a[i].h,&a[i].w);
			a[i].belong = 1;
		}
		sort(a,a+2*n,cmp);
		bob.clear();
        int ans=0;
        multiset<int>::iterator it;//定义迭代器。
		for ( i = 0; i <2* n; i++)
		{
			if(a[i].belong)
				 bob.insert(a[i].w);//插入bob卡片的宽。
			else
			{
				if(!bob.empty())
				{
			        	if(*bob.begin() <= a[i].w)
			          {
			        	  it = bob.lower_bound(a[i].w);//找到大于等于bob卡片宽的alice最小的卡片。
			        	   it--;//注意lower_bound取得是后一位,要自减。
			        	   ans++;
			        	   bob.erase(it);
			          }
				}
			}
	     }
		printf("%d\n",ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值