5-Binary String Matching

题目描述:
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入描述:
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出描述:
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入:
复制

3
11
1001110110
101
110010010010001
1010
110100010101011
样例输出:
3
0
3

这个题其实就是描述一个串里含有多少个另外一个串
不多说,上代码吧!

#include<stdio.h>
#include<string.h>
int main()
{
    int n;
    char a[11] , str[1010];
    while(~scanf("%d",&n))
    {
        getchar();
        while(n--)
        {
            gets(a);
            gets(str);
            int lena = strlen(a) ;
            int len = strlen(str);
            int sum = 0 ;
            int i = 0,j;
            for(int i=0; i<len; i++)
            {
                int k=i;
                for( j = 0 ; j < lena ; j++ ,k++)
                {
                    if(a[j] != str[k])
                        break;
                }
                if( j == lena )
                    sum++;
            }
            printf("%d\n",sum);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值