K小数查询主席树

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 57304 Accepted: 19808
Case Time Limit: 2000MS
Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.
Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output

5
6
3
Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
Source

Northeastern Europe 2004, Northern Subregion

%:pragma GCC optimize(3)
//垃圾map,常数暴大,下次绝对不用了!!! 
using namespace std;
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
#define r(x) scanf("%d",&x)
#define N 3000001
int L[N],R[N],val[N];
int xx[N],cnt,a[N],b[N];
int lc[N],rc[N],sz;
int root[N],n;
int x,y,k,m;
void pushup(int x)
{
    val[0]=0;
    val[x]=val[lc[x]]+val[rc[x]];
}
void build(int r1,int r2,int w)
{
    int mid=(L[r1]+R[r1])>>1;
    if(L[r1]==R[r1]) 
    {
        val[r1]++;return;
    }
    if(w>mid)
    {rc[r1]=++sz;L[sz]=mid+1;val[sz]=val[rc[r2]];R[sz]=R[r1];lc[r1]=lc[r2];build(rc[r1],rc[r2],w);}
    else
    {
        lc[r1]=++sz;L[sz]=L[r1];R[sz]=mid;val[sz]=val[lc[r2]];rc[r1]=rc[r2];build(lc[r1],lc[r2],w);
    }
    pushup(r1);
}
int query(int r1,int r2,int k)
{
    if(L[r1]==R[r1]) return xx[L[r1]];
    if(k<=(val[lc[r1]]-val[lc[r2]]))return query(lc[r1],lc[r2],k);
    return query(rc[r1],rc[r2],k-(val[lc[r1]]-val[lc[r2]]));
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++) 
    {scanf("%d",&a[i]);b[i]=a[i];}
    sort(b+1,b+n+1);
    xx[++cnt]=b[1];
    for(int i=2;i<=n;i++) 
    if(b[i]!=b[i-1])xx[++cnt]=b[i];
    for(int i=1;i<=n;i++)
    {
        a[i]=lower_bound(xx+1,xx+cnt+1,a[i])-xx;
    }
    for(int i=1;i<=n;i++)
    {
        root[i]=++sz;
        int r1=root[i],r2=root[i-1];
        L[r1]=1;R[r1]=cnt;
        build(r1,r2,a[i]);
    }
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&x,&y,&k);
        printf("%d\n",query(root[y],root[x-1],k));
    }
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值