PKU-2104-K-th Number

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 36045 Accepted: 11522
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

这道题貌似有很多种解法

我是用归并树做的

所谓归并树就是将 归并排序过程组成一个树

树上的每个节点就是非递减的。

以1 5 2 6 3 7为例:
把归并排序递归过程记录下来即是一棵归并树:
        [1 2 3 5 6 7]
    [1 2 5]      [3 6 7]
   [1 5] [2]    [3 6] [7]
  [1][5]         [6][3]
用对应的下标区间建线段树:(这里下标区间对应的是原数列)
            [1 6]
     [1 3]      [4 6]
  [1 2] [3]   [4 5][6]
  [1][2]      [4][5]

做法就是在归并树的根节点二分查找答案,然后用线段树查询rank值,因为线段树的每个节点与归并树的节点是一一对应的,而归并树的的节点元素是非递减的,因此可以用二分算出rank值。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 100000+10;

struct node{
    int lson,rson;
    int mid(){
        return (lson+rson)>>1;
    }
}tree[maxn*4];

int seg[25][maxn];
int n,m;
int num[maxn];
int sta,ed;

void build(int L,int R,int rt,int deep){
    tree[rt].lson = L;
    tree[rt].rson = R;
    if(L==R){
        seg[deep][L] = num[L];
        return;
    }
    int mid = tree[rt].mid();
    build(L,mid,rt<<1,deep+1);
    build(mid+1,R,rt<<1|1,deep+1);
    int i = L,j = mid+1,k = L;
    while(i <= mid && j <= R){
        if(seg[deep+1][i] < seg[deep+1][j]){
            seg[deep][k] = seg[deep+1][i];
            i++;
        }else{
            seg[deep][k] = seg[deep+1][j];
            j++;
        }
        k++;
    }
    while(i <= mid){
        seg[deep][k] = seg[deep+1][i];
        i++;
        k++;
    }
    while(j <= R){
        seg[deep][k] = seg[deep+1][j];
        j++;
        k++;
    }
    return;
}

int query(int rt,int dep,int key){
    if(tree[rt].lson >= sta && tree[rt].rson <= ed){
        int t = lower_bound(&seg[dep][tree[rt].lson],&seg[dep][tree[rt].rson]+1,key)-&seg[dep][tree[rt].lson];
        return t;
    }
    int mid = tree[rt].mid();
    int  res = 0;
    if(mid >= sta){
        res += query(rt<<1,dep+1,key);
    }
    if(mid < ed){
        res += query(rt<<1|1,dep+1,key);
    }
    return res;
}

int binary(int tk){
    int L = 1,R = n;
    while(L <= R){
        int mid = (L+R) >> 1;
        if(query(1,0,seg[0][mid]) > tk){
            R = mid-1;
        }else{
            L = mid+1;
        }
    }
    if(query(1,0,seg[0][R])==tk){
        return seg[0][R];
    }else{
        return seg[0][L];
    }
}

int main(){

    cin >> n >> m;
    for(int i = 1; i <= n; i++){
        scanf("%d",&num[i]);
    }
    build(1,n,1,0);
    while(m--){
        int k;
        scanf("%d%d%d",&sta,&ed,&k);
        printf("%d\n",binary(k-1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值