Max Sum(最大子序列和)(经典dp)

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6



#include<stdio.h>
int main()
{
    int n,m,i,j,end,begin,temp,max;
    int e,f,k,flag=1;
    int a[100005];
    scanf("%d",&n);
    k=1;
    while(n--)
    {
        begin=end=0;

        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
        }
        temp=0;
        max=-999999;
        begin=e=1;
        f=1;

        for(i=1;i<=m;i++)
        {
            temp+=a[i];

            if(temp>max)
            {
                e=begin;
                f=i;
                max=temp;
            }


            if(temp<0)
            {
                begin=i+1;
                temp=0;
            }



        }
        printf("Case %d:\n",k++);
        printf("%d %d %d\n",max,e,f);
        if(n!=0)
            printf("\n");
    }
    return 0;
}


  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
最大序列和是指给定一个整数序列,求其连续序列中的和最大的值。我们可以使用动态规划的方法来解决这个问题。 我们定义一个dp数组,dp[i]表示以第i个元素结尾的序列的最大和。对于dp[i]来说,它可以由两个情况得到:要么加上第i个元素,要么不加第i个元素。我们可以通过比较dp[i-1]+nums[i]和nums[i]的大小来确定dp[i]的值。 具体的实现步骤如下: 1. 定义一个dp数组,长度与给定整数序列长度相同,并将dp数组中的所有元素初始化为0。 2. 遍历给定整数序列,从第一个元素开始,逐个计算dp数组中的元素。 a. 如果dp[i-1]+nums[i]大于nums[i],说明前面的序列和是正数,对当前的和有增益效果,那么dp[i] = dp[i-1]+nums[i]。 b. 如果dp[i-1]+nums[i]小于等于nums[i],说明前面的序列和是负数或者0,对当前的和没有增益效果,那么dp[i] = nums[i]。 3. 遍历完整个给定整数序列后,找出dp数组中的最大值,即为最大序列和。 以下是具体的Java代码实现: public static int maxSubArray(int[] nums) { int[] dp = new int[nums.length]; dp[0] = nums[0]; int maxSum = dp[0]; for (int i = 1; i < nums.length; i++) { dp[i] = Math.max(dp[i-1] + nums[i], nums[i]); maxSum = Math.max(maxSum, dp[i]); } return maxSum; } 通过以上的实现,我们可以得到给定整数序列的最大序列和。这个算法的时间复杂度是O(n),其中n是给定整数序列的长度。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值