A Possible Tree(裸带权并查集)

 

问题 I: A Possible Tree

时间限制: 2 Sec  内存限制: 128 MB
提交: 61  解决: 20
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Alice knows that Bob has a secret tree (in terms of graph theory) with n nodes with n − 1 weighted edges with integer values in [0, 260 −1]. She knows its structure but does not know the specific information about edge weights.
Thanks to the awakening of Bob’s conscience, Alice gets m conclusions related to his tree. Each conclusion provides three integers u, v and val saying that the exclusive OR (XOR) sum of edge weights in the unique shortest path between u and v is equal to val.
Some conclusions provided might be wrong and Alice wants to find the maximum number W such that the first W given conclusions are compatible. That is say that at least one allocation of edge weights satisfies the first W conclusions all together but no way satisfies all the first W + 1 conclusions (or there are only W conclusions provided in total).
Help Alice find the exact value of W.

 

输入

The input has several test cases and the first line contains an integer t (1 ≤ t ≤ 30) which is the number of test cases.
For each case, the first line contains two integers n (1 ≤ n ≤ 100000) and c (1 ≤ c ≤ 100000) which are the number of nodes in the tree and the number of conclusions provided. Each of the following n−1 lines contains two integers u and v (1 ≤ u, v ≤ n) indicating an edge in the tree between the u-th node and the v-th node. Each of the following c lines provides a conclusion with three integers u, v and val where 1 ≤ u, v ≤ n and val ∈ [0, 260 − 1].

 

输出

For each test case, output the integer W in a single line.

 

样例输入

2
7 5
1 2
2 3
3 4
4 5
5 6
6 7
1 3 1
3 5 0
5 7 1
1 7 1
2 3 2
7 5
1 2
1 3
1 4
3 5
3 6
3 7
2 6 6
4 7 7
6 7 3
5 4 5
2 5 6

 

样例输出

3
4

 

[提交][状态]

题意:有一棵树,已知树的结构,不知道树的权值,给m次询问,每次询问代表节点a到节点b的权值是否为c,求最多能满足多少组这样的询问。

分析:很明显的并查集,当时太长没做,超级简单超级水。一开始给的n个关于树的结构,是一点用也没有,但是总觉得不放心,打开题解小看一眼,真的是卵用都没有。直接对m次操作搞就行了,一个裸的带权并查集。

1、对于每次询问,并查集逐渐完善这棵树。

2、用sum[i]表示i到根节点所有边权的异或和。

3、并查集维护这个异或和。

4、每次询问都进行判断,如果a,b根节点相同,看一下sum[a]^sum[b]是否等于c。如果不相同,就他们并起来,更新sum[fx]。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#define INF 0x3f3f3f3f
#define FAST_IO ios::sync_with_stdio(false)
const double PI = acos(-1.0);
const double eps = 1e-6;
const int MAX=1e5+10;
const int mod=1e9+7;
typedef long long ll;
using namespace std;
#define gcd(a,b) __gcd(a,b)
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
inline ll qpow(ll a,ll b){ll r=1,t=a; while(b){if(b&1)r=(r*t)%mod;b>>=1;t=(t*t)%mod;}return r;}
inline ll inv1(ll b){return qpow(b,mod-2);}
inline ll exgcd(ll a,ll b,ll &x,ll &y){if(!b){x=1;y=0;return a;}ll r=exgcd(b,a%b,y,x);y-=(a/b)*x;return r;}
inline ll read(){ll x=0,f=1;char c=getchar();for(;!isdigit(c);c=getchar()) if(c=='-') f=-1;for(;isdigit(c);c=getchar()) x=x*10+c-'0';return x*f;}
//freopen( "in.txt" , "r" , stdin );
//freopen( "data.txt" , "w" , stdout );
int pre[MAX];
int sum[MAX];
int n,m,ans;
int find(int x)
{
    int k=pre[x];
    if(x!=pre[x])
    {
        pre[x]=find(pre[x]);
        sum[x]=sum[x]^sum[k];
    }
    return pre[x];
}
 
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d%d",&n,&m);
 
        memset(sum,0,sizeof(sum));
        for(int i=0;i<=n;i++)
            pre[i]=i;
 
        for(int i=1;i<=n-1;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
        }
        ans=0;///数据不完善,ans应该初始化为m+1.
        for(int i=1;i<=m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(ans)///这里根据上面也该写成ans!=m+1.
                continue;
 
            int fx=find(a);
            int fy=find(b);
            if(fx!=fy)
            {
                pre[fx]=fy;
                sum[fx]=sum[a]^c^sum[b];
            }
            else if(fx==fy && (sum[a]^sum[b])!=c)
                ans=i;
        }
        printf("%d\n",ans-1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值