1034: A+B Problem(V)

1034: A+B Problem(V)

1.描述

Your task is to calculate the sum of some integers.
输入
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

输出
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入
2
4 1 2 3 4
5 1 2 3 4 5
样例输出
10
15

翻译

题目描述
您的任务是计算某些整数的总和。

输入
输入在第一行中包含整数 N,然后 N 行跟随。每行以整数 M 开头,然后 M 整数在同一行中跟随。

输出
对于每组输入整数,应在一行中输出它们的总和,并在输入中每行输出一行。

样例输入
2
4 1 2 3 4
5 1 2 3 4 5
样例输出
10
15

2.代码

#include<stdio.h>
int main()
{
    int n,i,j,m,x;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&x);
        m=0;
        for(i=1; i<=x; i++)
        {
            scanf("%d",&j);
            m+=j;
        }
        printf("%d\n",m);
    }
    return 0;
}

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

汤米先生

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值