1096 A+B for Input-Output Practice (VIII)

这篇博客介绍了程序设计题1096的求解过程,主要涉及C语言编程。题目要求计算输入的多组整数之和,并按特定格式输出结果。博主分享了在处理输出格式时遇到的问题和解决方案,强调解题时需严谨遵循题目要求,不应过度解读。同时,博主以老师的话作结,提醒程序员在编程时要注重理解题目,避免主观臆断。
摘要由CSDN通过智能技术生成
Problem

Description Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6

解题过程

#include <stdio.h>
int main()
{
 	int n,num,x,i,m,a;
 	scanf("%d",&n);
 	a=n;
 	for(i=0;i<n;i++,a--)
 	{
  		scanf("%d",&m);
  		num=0;
  		while(m--)
  		{
   			scanf("%d",&x);
   			num+=x;
  		}
  	
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值