POJ 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20587 Accepted: 10723

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题目链接:http://poj.org/problem?id=2752

题意:输入一个长度不超过400000的字符串,按从小到大的顺序输出其所有前缀等于后缀的前后缀长度。

解题思路:最开始看到题目感觉不是那么好下手,因为求的是字符串自身前缀和后缀的匹配,看到题目的时候还停留在KMP,其实将题目给的样例仔细一分析就是一个扩展KMP,记录str[i...len](len为输入的字符串的长度)与字符串的最长公共前缀存于extend[i],如果最长公共前缀的长度与后缀长度相等,那么此时后缀的长度就是满足前缀长度等于后缀长度的。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXL = 4e5 + 10; //输入字符串的最长长度 
char S[MAXL]; 
int extend[MAXL]; //扩展数组 
void get_extend(int n) //获得extend数组  
{
	extend[0]=n;
	int a,p;
	for(int i=1,j=-1;i<n;i++,j--)
	{
		if(j<0 || i+extend[i-a]>=p)
		{
			if(j<0) j=0,p=i;
			while(p<n && S[j]==S[p]) 
			{
				j++;
				p++;
			}
			extend[i]=j;
			a=i;
		}
		else extend[i]=extend[i-a];
	}
}
void solve()
{
	int n=strlen(S);
	bool flag=false;  
	get_extend(n); //得到扩展数组,也就是字符串后缀与字符串本身的最长公共前缀 
	for(int i=n-1;i>=0;i--) 
	{
		int l=n-i;
		if(l==extend[i]) //满足条件的后缀长度,字符串后缀与字符串本身的最长公共前缀等于后缀长度 
		{
			if(flag) printf(" "); //输出格式控制 
			printf("%d",l);
			flag=true;
		}
	}
	printf("\n");
}
int main(void)
{
	while(scanf("%s",S)==1) //输入字符串 
	{
		solve(); //处理函数 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值