HDU 2594 Simpsons’ Hidden Talents

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10017    Accepted Submission(s): 3461

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 
Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 
Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 
Sample Input
  
  
clinton homer riemann marjorie
 
Sample Output
  
  
0 rie 3

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2594

题意:输入两个字符串s1和s2,求s1的前缀与s2的后缀完全匹配的最长后缀。将最长后缀和长度一起输出,如果不存在那么输出0。

解题思路:就是扩展KMP,当s2的扩展数组extend[i]=后缀的长度是,那么说明此时的后缀和前缀是完全匹配的,而且extend数组是从左到右求解的,所以第一次满足条件的就是最长后缀。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXL = 5e4 + 10; //字符串最大长度 
char s1[MAXL]; //串s1 
char s2[MAXL]; //串s2 
int extend1[MAXL]; //s1的本身匹配 
int extend2[MAXL]; //s2与s1的匹配 
void get_extend1(int m) //获得s1的自身匹配数组 
{
	extend1[0]=m; //扩展KMP 
	int a,p;
	for(int i=1,j=-1;i<m;i++,j--)
	{
		if(j<0 || i+extend1[i-a]>=p)
		{
			if(j<0) j=0,p=i;
			while(p<m && s1[p]==s1[j])
			{
				j++;
				p++;
			}
			extend1[i]=j;
			a=i;
		}
		else extend1[i]=extend1[i-a];
	}
}
int get_extend2(int n,int m)
{
	int a,p;
	for(int i=0,j=-1;i<n;i++,j--)
	{
		if(j<0 || i+extend1[i-a]>=p)
		{
			if(j<0) j=0,p=i;
			while(p<n && s1[j]==s2[p])
			{
				j++;
				p++;
			}
			extend2[i]=j;
			a=i;
		}
		else extend2[i]=extend1[i-a];
		if(extend2[i]==n-i) return n-i; //第一次满足条件的后缀 
	}
	return 0; //不存在这样的后缀 
}
void solve()
{
	int n=strlen(s2);
	int m=strlen(s1);
	get_extend1(m);
	int l=get_extend2(n,m);
	if(l)
	{
		printf("%s %d\n",s2+n-l,l); //输出后缀和后缀长度 
	}
	else printf("0\n");
	
}
int main(void)
{
	while(scanf("%s%s",s1,s2)==2) 
	{
		solve(); //处理函数 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值