poj 2236 Wireless Network 并查集

Wireless Network , 原文链接, click here

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意:给你一个N和一个d,N表示有N台电脑,编号从1开始,d表示的是给定的距离,如果两台电脑的距离不大于d就能够直接相连.之后输入"O a"代表编号为a的电脑被修复,"S a b"代表的是查询编号为a和编号为b 的电脑是否能够直连.

这是一道很模板的并查集,需要每次都遍历一遍,之前想着每次遍历可能会超时,但是好像除了重新遍历一遍也没有别的思路可以写的了,还有就是输出坑了,我一直以为是”FALL”结果WA了好多次,感觉改了这么久应该对了,结果到最后想了想问题可能出在输出上面,仔细看了看,发现是”FAIL”,英语不好真心累!!
扯多了,上代码.


#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<string>
#include<string.h>
using namespace std;
const int maxn= 1100;
int f[maxn],n,d;
bool vis[maxn];
struct node
{
    int x,y;
}a[maxn];
//找爹函数;
int find(int x)
{
    if(f[x]!=x)
        f[x]=find(f[x]);
    return f[x];
}
//求距离;
int dis(node a,node b)
{
    return ((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main()
{
    scanf("%d%d",&n,&d);
    char q[2];
    int x,y,abc;
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++)
    {
        f[i]=i;//初始化f[]数组;
        scanf("%d%d",&a[i].x,&a[i].y);
    }
    while(~scanf("%s",q))
    {
        if(q[0]=='O')
        {
            scanf("%d",&abc);
            x=find(abc);
            vis[abc]=true;
            for(int i=1;i<=n;i++)
                if(i!=abc&&vis[i])//判断,如果该电脑没有被操作过;
                {
                    y=find(i);
                    if(x!=y&&d*d>=dis(a[i],a[abc]))//如果父亲结点不一样,赋值;
                        f[y]=x;
                }
        }
        else
        {
            int c,d;
            scanf("%d%d",&c,&d);
            if(find(c)==find(d))//判断是否父亲节点一样;
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值