poj 2533 Longest Ordered Subsequence (最长不下降子序列)

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence (  a1a2, ...,  aN) be any sequence (  ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output

4


题目大意:就是让你求最长的不下降子序列


题目分析:很简单的一道dp,只是为了巩固一下自己对dp的理解,所以又做了一下,状态转移方程就是

  if(a[j]>a[i])  dp[j]=max(dp[i]+1,dp[j]);

  不过这道题目还有二分的写法,好像是省时间的,我

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define maxn 10005
int dp[maxn],a[maxn];
int main(){
	int n;
	while((scanf("%d",&n))!=EOF){
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		int ans=0;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
	    for(int i=1;i<=n;i++){
	    	for(int j=i+1;j<=n;j++){
	    		if(a[j]>a[i]&&dp[i]+1>dp[j])
	    		  dp[j]=dp[i]+1;
			}
			if(dp[i]>ans)
			 ans=dp[i];
		}
		printf("%d\n",ans+1);
	}
	return 0;
} 

然后,还有一种是省时间的二分法求最长不下降子序列方法。

就是开一个数组用来存储当前最长长度为k的不下降子序列的末尾元素,每次读入数据,如果大于f【k】,则更新k,k++,否则就把这个数据放在大于这个元素的最小f【i】。然后查找方法用二分,所以省时间。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define maxn 1005
int f[maxn];
int search(int a,int l,int r){
	int m;
	while(l<=r){
		m=(l+r)/2;
		if(f[m] == a){
		 l=m;
		 return l;	
		}
		  
		else if(f[m] > a)
			r=m-1;
		else l=m+1;
	}
	return l;//确保返回的是大于a的最小值 
}
int main(){
	int n,t,a;
	while((scanf("%d",&n))!=EOF){
		memset(f,0,sizeof(f));	t=0;
		for(int i=1;i<=n;i++){
		
			scanf("%d",&a);
			int k=search(a,1,t);
			if(k<=t)  f[k]=a;
			else {
			  t=t+1;
			  f[t]=a;
			}
		}
		 printf("%d\n",t);
	}
	return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值