HDU 1711 Number Sequence (kmp)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24668    Accepted Submission(s): 10471


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 

Recommend
lcy


题目大意:就是给你两个数组,让你找出第二个数组在第一个数组的位置,如果没有就输出-1


题目分析:比较裸的kmp算法,就是把字符串改成int型数组,换一下函数就行了,不过那个next数组我居然不能交,换成gnext数组才不会出现编译错误这样的问题,真是尴尬


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e6+7;
int a[maxn],b[maxn],gnext[maxn];
int n,m;
void calnext(int *t){
	int len=m;
	gnext[0]=-1;
	int i = 0 , ct = gnext[0];
	while(i < len-1){
		
		if(ct < 0 || t[i] == t[ct])
		  gnext[++i] = ++ct;
		
		else ct = gnext[ct];
	}
}
int kmp(int *s,int *t){//返回主串中匹配位置的第一个,如果无法匹配就返回-1; 
	 int lens = n;
	 int lent = m;
	 calnext(t);
	 int i=0,j=0;
	 while ( i < lens && j<lent ){
	 	  if( j < 0 || s[i] == t[j]){
	 	  	 i++;j++;
		   }
		   else
		     j = gnext[j];
		   if( j == lent)   return (i-j+1);
	 }
	 return -1;
}
int main(){
	int t;
	scanf("%d",&t);
	while( t-- ){
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
		  scanf("%d",&a[i]);
		for(int j=0;j<m;j++)
		  scanf("%d",&b[j]);
		calnext(b);
		int ans = kmp(a,b);
		printf("%d\n",ans);
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值