poj3126 BFS

23 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=3126

 

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

 

 

   题目给出2个4位素数,要求求出经过几次变换从左成右边的素数,要求变换次数最少,变换规则:从左边素数开始,每次变换一位,变换后还得是素数,直至变成右边。

 

   求最小步数,简单BFS就可,关键是搜索状态使用素数筛优化一下,O(nloglogn)的复杂度求出4位所有素数。改变状态时只需if(is_prime[x])即可。

   32ms AC

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

struct node
{
 int x,step;
};
int is_prime[10000];

void seive()
{
 int i,j;
 int p=0;
 for(i=0;i<=9999;i++)
  is_prime[i]=1;
 is_prime[0]=is_prime[1]=0;
 for(i=2;i<=9999;i++)
  if(is_prime[i])
  {
   for(j=2*i;j<=9999;j+=i)
    is_prime[j]=0;
  }
}

int BFS(int a,int b)
{
 int vis[10000]={0};
 queue<node>q;
 node t;
 t.x=a;
 t.step=0;
 q.push(t);
 vis[t.x]=1;
 while(!q.empty())
 {
  node p=q.front();
  if(p.x==b)
   return p.step;
  q.pop();
  int i;
  int d=p.x%10;
  int c=(p.x/10)%10;
  int b=(p.x/100)%10;
  int a=p.x/1000;
  for(i=0;i<=9;i++)
  {
    if(is_prime[a*1000+i*100+c*10+d]&&!vis[a*1000+i*100+c*10+d])
    {
     t.x=a*1000+i*100+c*10+d;
     t.step=p.step+1;
     vis[a*1000+i*100+c*10+d]=1;
     q.push(t);
    }
    if(is_prime[a*1000+b*100+i*10+d]&&!vis[a*1000+b*100+i*10+d])
    {
     t.x=a*1000+b*100+i*10+d;
     t.step=p.step+1;
     vis[a*1000+b*100+i*10+d]=1;
     q.push(t);
    }
    if(is_prime[a*1000+b*100+c*10+i]&&!vis[a*1000+b*100+c*10+i])
    {
     t.x=a*1000+b*100+c*10+i;
     t.step=p.step+1;
     vis[a*1000+b*100+c*10+i]=1;
     q.push(t);
    }
   if(i!=0)
   {
    if(is_prime[i*1000+b*100+c*10+d]&&!vis[i*1000+b*100+c*10+d])
    {
     t.x=i*1000+b*100+c*10+d;
     t.step=p.step+1;
     vis[i*1000+b*100+c*10+d]=1;
     q.push(t);
    }
   }
  }
 }
 return -1;
}

int main()
{
 int a,b;
 int T;
 seive();
 scanf("%d",&T);
 while(T--)
 {
  cin>>a>>b;
  int res=BFS(a,b);
  if(res==-1)
   printf("Impossible\n");
  else
   printf("%d\n",res);
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值