poj3669 BFS

23 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=3669

 

Meteor Shower
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9809 Accepted: 2741

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5

 

     题目大意:    流星要摧毁地球,Bessie 掐指一算,知道了所有陨石落下的地点和时间(我也是醉了),每一时间单位可以走相邻4格中安全的格子,要求求出最终安全的最小步数。

 

这一题比较坑爹,有几点要注意

1.陨石落下一次炸掉给出坐标和坐标周围4格,所以直接初始化周围4格和中间的时间,同时注意第三条。

2.陨石落过后的区域也不能走,也就是当前坐标只能在陨石落下前走。

3.陨石可以在同一坐标多次落下,这时时间取小的,也就是取最早落下的时间算。

4.题目其实没有规定地图的大小,给出的x,y范围其实只是陨石可能落下的范围(x/y)【0~300】。也就是说走到一个不可能被陨石砸到的地方或者300之外也可以。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define inf 0x0fffffff
#define min(a,b)(a>b?b:a)

struct node
{
 int x,y,time;
};
int M;
int dir[][2]={0,1,0,-1,1,0,-1,0};
int map[302][302];

int judge(int x,int y)
{
 if(x>=0&&x<=300&&y>=0&&y<=300)
  return 1;
 return 0;
}
int BFS(int x,int y)
{
 int vis[302][302]={0};
 queue<node>q;
 node t;
 t.x=x;
 t.y=y;
 t.time=0;
 q.push(t);
 vis[x][y]=1;
 while(!q.empty())
 {
  node p=q.front();
  if(map[p.x][p.y]==inf||p.x>300||p.y>300)
   return p.time;
  q.pop();
  int i;
  for(i=0;i<4;i++)
  {
   int tx=p.x+dir[i][0];
   int ty=p.y+dir[i][1];
   t.x=tx;
   t.y=ty;
   t.time=p.time+1;
   if(t.x>=0&&t.y>=0&&t.time<map[tx][ty]&&!vis[tx][ty])
   {
    q.push(t);
    vis[tx][ty]=1;
   }
  }
 }
 return -1;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 scanf("%d",&M);
 int i,j;
 for(i=0;i<302;i++)
  for(j=0;j<302;j++)
   map[i][j]=inf;
 while(M--)
 {
  int x,y,time;
  scanf("%d%d%d",&x,&y,&time);
  map[x][y]=min(time,map[x][y]);
  for(i=0;i<4;i++)
  {
   int tx=x+dir[i][0];
   int ty=y+dir[i][1];
   if(judge(tx,ty))
    map[tx][ty]=min(time,map[tx][ty]);
  }
 }
 if(map[0][0]==0)
  printf("-1\n");
 else
 printf("%d\n",BFS(0,0));
 return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值