poj2393 贪心

17 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2393

 

Yogurt factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7087 Accepted: 3626

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S.

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS:
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

Source

 

每一周的出产量是Y_i,每一个生产成本C_i,这一周可以多生产,每一件存一个星期花费S,问最终的最少花费。

 

思路:很好的贪心题目,一开始想到是动归,当前星期i的最少花费=min(前面某一个星期j的最少花费+(j+1,i)件物品分别存储(1~i-j)个星期的花费,当前星期的花费)。

其实可以发现根本不需要这么麻烦,通过上一个星期的C_i+S<这个星期的花费,因为数量一样,所以总值最小。记录上一层的最优花费和这一层比较,如果优就更新最优花费,这样保证不必对存的星期数再去判断是否最优,存的星期数在每一层更新的时候跟着就更新。

 

#include<iostream>
#include<cstdio>
using namespace std;
#define inf 0x0fffffff
#define ll long long
#define min(a,b)(a>b?b:a)

int main()
{
 int N,S;
 int i;
 ll ans=0;
 int prev_c=inf;
 scanf("%d%d",&N,&S);
 for(i=0;i<N;i++)
 {
  int c,y;
  scanf("%d%d",&c,&y);
  prev_c=min(c,prev_c+S);
  ans+=prev_c*y;
 }
 printf("%I64d\n",ans);
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值