poj3268 dijsktra

 

 

如题:http://poj.org/problem?id=3268

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13502 Accepted: 6082

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

 

 

题目大意:给出个顶点,M条单向边,给出源点X,要求求出从一个点到X点再从X点回到那个点的距离最长。

 

题目思路:顶点1000,floyd  O(1000^3)必超,而且也用不到那么多距离,使用到的是2个距离,第一个是从一点到X的最短距离,第二个是从X到某一点的最短距离,从X到任意一点的最短距离一次dijsktra求得,从任一点到X的最短距离,只需要将所有边取反,再用一次dijsktra求X到其他点的距离。

 

本来很正确的思路,最后wa了好久,最后才发现dijsktra函数中我传的一个局部参数dis竟然在一个地方使用的全局参数d,以后这种有多个图或距离的题全局变量数组如果不太大还是放在main里面的好,这样错了直接就检查出来了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
#define max(a,b)(a>b?a:b)

struct edge
{
 int to,cost;
 edge(){}
 edge(int a,int b):to(a),cost(b){}
};

vector<edge>G[1005];
vector<edge>G1[1005]; //取反
int d1[1005];
int d[1005];
int N,M,X;
typedef pair<int,int>P; //编号,距离

class cmp
{
public:
 bool operator()(P &a,P &b)
 {
  return a.second>b.second;
 }
};

void dijsktra(int dis[],vector<edge>gra[],int s)
{
 priority_queue<P,vector<P>,cmp>que;
 int i;
 for(i=0;i<1005;i++)
  dis[i]=0x0fffffff;
 dis[s]=0;
 que.push(P(s,0));
 while(!que.empty())
 {
  P p=que.top();
  que.pop();
  int v=p.first;
  if(p.second>dis[v])
    continue;
  int i;
  for(i=0;i<gra[v].size();i++)
  {
   edge e=gra[v][i];
   if(dis[e.to]>dis[v]+e.cost)
   {
    dis[e.to]=dis[v]+e.cost;
    que.push(P(e.to,dis[e.to]));
   }
  }
 }
}
int main()
{
 cin>>N>>M>>X;
 int i;
 for(i=1;i<=M;i++)
 {
  int a,b,c;
  scanf("%d%d%d",&a,&b,&c);
  G[a].push_back(edge(b,c));
  G1[b].push_back(edge(a,c));
 }
  dijsktra(d,G,X);
  dijsktra(d1,G1,X);
   int res=-0x0fffffff;
  for(i=1;i<=N;i++)
   if(i!=X&&d[i]!=0x0fffffff&&d1[i]!=0x0fffffff)
   res=max(res,d[i]+d1[i]);
  printf("%d\n",res);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值