poj2456 二分搜索

27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2456

 

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6930 Accepted: 3450

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

Source

 

 

 

思路:设f(d)为是否满足任意两头牛距离大于等于d。在区间0-(X数组最大值*2+1)中搜索满足f的,不断缩小区间,直到r-l<=1

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int X[100005];
int N,C;
int f(int d)
{
 int i;
 int last=1;
 for(i=1;i<C;i++)
 {
  int now=last+1;
  while(now<=N&&X[now]-X[last]<d)
   now++;
  if(now>N)
   return 0;
  last=now;
 }
 return 1;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 cin>>N>>C;
 int i;
 for(i=1;i<=N;i++)
  scanf("%d",&X[i]);
 sort(X+1,X+1+N);
 int l=0,r=X[N]*2+1;
 while(r-l>1)
 {
  int mid=(l+r)/2;
  if(f(mid))
   l=mid;
  else
   r=mid;
 }
 printf("%d\n",l);
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值