poj1131 高精度

 

如题:http://poj.org/problem?id=1131

Octal Fractions
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6749 Accepted: 3696

Description

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

Input

The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

Output

Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]


where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

Sample Input

0.75
0.0001
0.01234567

Sample Output

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]

Source

 

 

题目思路:以0.123为例初始时:

 0[8]=0[10]

两边加上3[8]: 3[8]=3[10]

两边除以8[10]:0.3[8]=0.375[10]

两边加上2[8]: 2.3[8]=2.375[10]

两边除以8[10]:0.23[8]=0.296875[10]

两边加上1[8]: 1.23[8]=1.296875[10]

两边除以8[10]:0.123[8]=0.162109375[10]

 

每次算出结果数组的最低一位,一直算到最高位。直接贴代码吧,不是很好说,按照程序笔算一下就懂。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

char s1[20],s2[50],s3[20];

int main()
{
// freopen("C:\\1.txt","r",stdin);
 while(~scanf("%s",s1))
 {
  int l=strlen(s1);
  strcpy(s3,s1);
  int len=3*(l-2);  //最终串的长度
  s2[0]='0';
  s2[1]='.';
  int i,j;
  j=2;
  int t=0;
  while(t<len)
  {
   int k=0;
   t++;
   for(i=l-1;i>1;i--)
   {
    int g=(s1[i]-'0')*10+k;
    k=g/8;
    s1[i]=g%8+'0';
   }
   s2[j++]=k+'0';
  }
  s2[j]='\0';
  printf("%s [8] = ",s3);
  j--;
  while(s2[j]=='0')
   j--;
  for(i=0;i<=j;i++)
   printf("%c",s2[i]);
  printf(" [10]\n");
 }
 return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值