poj3616 dp

31 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=3616

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5939 Accepted: 2487

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

 

 

 

 

思路:

首先说一点,当2段间隔==r的时候是可取的,题目描述不精确

题目n为1000000,m为1000

有2种dp策略,一种是O(n)复杂度,一种O(m*m)复杂度,但是考虑到在对n的dp中,dp[i]为到i时间前的最大挤奶价值,而数据只有不到m(1000)组,浪费了很多的时间去对于一些不必要的时间dp。因此还是采用O(m*m)的方法。

首先将m组数据按照结束时间从小到大排序。

dp[i]表示前i组的最大价值,输出结果是dp[m]。

递推关系:

dp[i]=max(dp[j]+value[i],dp[i-1]);  j∈[i-1,i]中并且time[i]-t[j]>=r的第一组,其中t[i]表示的是到第i组最优结果中最后一组的结束时间。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define max(a,b)(a>b?a:b)

struct node
{
 int start,end,value;
}a[1001];


int dp[1001];
int t[1001];


bool operator < (node a,node b)
{
 return a.end<b.end;
}

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int n,m,r;
 int i,j;
 cin>>n>>m>>r;
 for(i=1;i<=m;i++)
 {
  int s,e,v;
  cin>>s>>e>>v;
  a[i].start=s;
  a[i].end=e;
  a[i].value=v;
 }
 sort(a+1,a+1+m);
 for(i=1;i<=m;i++)
 {
  int x=0;
  for(j=i-1;j>=1;j--)
   if(a[i].start-t[j]>=r)
   {
    x=dp[j];
    break;
   }
  if(dp[i-1]>x+a[i].value)
  {
   dp[i]=dp[i-1];
   t[i]=dp[i-1];
  }
  else
  {
   dp[i]=x+a[i].value;
    t[i]=a[i].end;
  }
 }
 cout<<dp[m]<<endl;
 return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值