poj2823 单调队列

 

 

刚刚学习了单调队列,来练习一道,等会去试试多重背包。

 

如题:http://poj.org/problem?id=2823

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 47025 Accepted: 13585
Case Time Limit: 5000MS

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
1 [3  -1  -3] 5  3  6  7 -33
1  3 [-1  -3  5] 3  6  7 -35
1  3  -1 [-3  5  3] 6  7 -35
1  3  -1  -3 [5  3  6] 7 36
1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

 

思路:单调队列也就是在一个队列中维护一个单调不减或单调不增的序列,每次用的时候从头取出来。插入的时候在尾部,并在头部删除无效的值,具体百度。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;

int a[1000005];
typedef pair<int,int>P;
int top1,rear1,top2,rear2;
P que1[1000005]; //单调减
P que2[1000005]; //单调加

void insert(int x,int i)
{
  while(rear1>top1&&x<que1[rear1-1].first)
   rear1--;
  que1[rear1++]=P(x,i);
  while(rear2>top2&&x>que2[rear2-1].first)
   rear2--;
  que2[rear2++]=P(x,i);
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 int n,k;
 cin>>n>>k;
 int i;
 for(i=1;i<=n;i++)
  cin>>a[i];
 top1=rear1=0;
 top2=rear2=0;
 vector<int>res1;
 vector<int>res2;
 for(i=1;i<=k;i++)
 {
  insert(a[i],i);
 }
 for(i=k+1;i<=n;i++)
 {
  res1.push_back(que1[top1].first);
  res2.push_back(que2[top2].first);
  insert(a[i],i);
  while(que1[top1].second<i-k+1)
   top1++;
  while(que2[top2].second<i-k+1)
   top2++;
 }
 res1.push_back(que1[top1].first);
 res2.push_back(que2[top2].first);
 for(i=0;i<res1.size();i++)
 {
  printf("%d%c",res1[i],i==res1.size()-1?'\n':' ');
 }
 for(i=0;i<res2.size();i++)
 {
  printf("%d%c",res2[i],i==res2.size()-1?'\n':' ');
 }
 return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值