poj1703 并查集

 

 

如题:http://poj.org/problem?id=1703

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36346 Accepted: 11153

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

 

 

 

思路:回顾了我之前做这题的代码,是根据如果2个人能确定关系,就并入一个集合,在根据rela数组来判断是否是一个帮派,这里换了一种方法,更好理解,对并查集很多问题都能很好的解决。

对于编号i的人,i代表i是A帮派,i+n代表i是B帮派,给出D a b时,就Union(a,b+n);Union(a+n,b)。给出查询时,if(same(a,b+n)||same(a+n,b)) ,则ab不同帮派,if(same(a,b)||same(a+n,b+n))则是相同帮派,否则不能确定。注意数据量很大,一定要用scanf、

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100005

int f[N*2];
int rank[N*2];
int find(int x)
{
 if(x==f[x])
  return x;
 return f[x]=find(f[x]);
}
void Union(int x,int y)
{
 int fx=find(x);
 int fy=find(y);
 if(rank[fx]>rank[fy])
 {
  f[fy]=fx;
 }
 else
 {
  f[fx]=fy;
  if(rank[fx]==rank[fy])
   rank[fy]++;
 }
}
int same(int x,int y)
{
 if(find(x)==find(y))
  return 1;
 return 0;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 int T;
 cin>>T;
 while(T--)
 {
  int n,m;
  scanf("%d%d",&n,&m);
  int i;
  for(i=1;i<=n*2;i++)
  {
   f[i]=i;
   rank[i]=0;
  }
  while(m--)
  {
   char str[5];
   int a,b;
   scanf("%s%d%d",str,&a,&b);
   if(str[0]=='D')
   {
    Union(a,b+n);
    Union(a+n,b);
   }
   else
   {
    if(same(a,b+n)||same(a+n,b))
     cout<<"In different gangs."<<endl;
    else if(same(a,b)||same(a+n,b+n))
     cout<<"In the same gang."<<endl;
    else
     cout<<"Not sure yet."<<endl;
   }
  }
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值