POJ 3111 K Best(二分——最大化平均值)

这是一个关于最大化珠宝单位价值的问题。给定n个珠宝,每个珠宝有值vi和重量wi,Demy希望保留k个珠宝,使得这k个珠宝的平均值(特定价值)最大化。通过二分查找,确定满足条件的最大单位价值x,并选择vi - xi*wi之和最大的k个珠宝。题目来自Northeastern Europe 2005比赛。
摘要由CSDN通过智能技术生成

K Best
Time Limit: 8000MS Memory Limit: 65536K
Total Submissions: 10457 Accepted: 2695
Case Time Limit: 2000MS Special Judge
Description

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3
Sample Output

1 2
Source

Northeastern Europe 2005, Northern Subregion

题意:有N个珠宝、选K个使这K个的单位质量的价值X最高

做法:对X二分,对于每个X我们选出vi-wi*x最大的K个,看是不是能>=0,如果能满足条件,说明x小了
为什么能这样做呢 x=∑v/∑ w 移项得
∑v-x*∑w=0=∑(vi-x*wi)这个值随着x的增大而减小,满足二分的单调性条件,所以可以二分做。

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 100010
using namespace std;
int n,k;
struct Node
{
    int id,v,w;
    double a;
}node[maxn];
void setup(double x)
{
    for(int i=0;i<n;i++)
    {
        node[i].a=node[i].v-node[i].w*x;
    }
}
bool cmp(const Node &x,const Node & y)
{
    return x.a>y.a;
}

bool judge(double x)
{
    setup(x);
    double ans=0;
    sort(node,node+n,cmp);
    for(int i=0;i<k;i++)
    {
        ans+=node[i].a;
    }
    return ans>=0;
}


int main()
{
    int a,b;
    int minw=0;
    int sumv=0;
    while(scanf("%d%d",&n,&k)==2)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            node[i].id=i+1;
            node[i].v=a;
            node[i].w=b;
        }
        double st=0,ed=1e7,mid;
        for(int i=0;i<100;i++)
        {
            mid=(st+ed)/2;
            if(judge(mid))
            {
                st=mid;
            }
            else ed=mid;
        }
        for(int i=0;i<k;i++)
        {
            printf("%d ",node[i].id);
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值