POJ 3613 Cow Relays k步最短路 (floyd + 矩阵快速幂)

Cow Relays
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7738 Accepted: 3033
Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

  • Line 1: Four space-separated integers: N, T, S, and E
  • Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

  • Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9
Sample Output

10
Source

USACO 2007 November Gold

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define maxn 1010
using namespace std;
const int inf = 0x3f3f3f3f3f;
int n,t,s,e;
int num;
int v[maxn];
int map[maxn][maxn];
int tmp[maxn][maxn];
int ans[maxn][maxn];
int dis[maxn][maxn];
int vis[maxn];
void floyd(int c[][maxn], int a[][maxn], int b[][maxn])
{
    for(int k = 0; k < num; k++)
        for(int i = 0; i < num; i++)
            for(int j = 0; j < num; j++)
                if(c[v[i]][v[j]] > a[v[i]][v[k]] + b[v[k]][v[j]])
                    c[v[i]][v[j]] = a[v[i]][v[k]] + b[v[k]][v[j]];
}
void cop(int a[][maxn], int b[][maxn])
{
    for(int i = 0; i < num; i++)
        for(int j = 0; j < num; j++)
        {
            a[v[i]][v[j]] = b[v[i]][v[j]];
            b[v[i]][v[j]] = inf;
        }
}

void quickpower(int k)
{
    while(k)
    {
        if(k & 1)
        {
            floyd(dis, ans, map);//相当于dis=ans*map
            cop(ans, dis);//ans=dis
        }
        floyd(tmp, map, map);//map=map*map
        cop(map, tmp);
        k >>= 1;
    }
}
void init()
{
 for(int i = 0; i <= 1000; i++)
    {
        for(int j = 0; j <= 1000; j++)
        {
            map[i][j] = inf;
            tmp[i][j] = inf;
            dis[i][j] = inf;
            ans[i][j] = inf;
        }
        ans[i][i] = 0;
    }
    num = 0;
}
int main()
{
    int x, y, w;
    scanf("%d%d%d%d", &n, &t, &s, &e);
    init();
    for(int i = 0; i < t; i++)
    {
        scanf("%d%d%d", &w, &x, &y);
        if(!vis[x])
        {
            vis[x] = 1;
            v[num++] = x;
        }
        if(!vis[y])
        {
            vis[y] = 1;
            v[num++] = y;
        }
        if(map[x][y] > w)
            map[x][y] = map[y][x] = w;
    }
    quickpower(n);
    printf("%d\n", ans[s][e]);

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值