Contestant Division(树形dp)

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input
There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output
For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input
7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0
Sample Output
Case 1: 1

做法就是把以x为根的学生总数求出来再用总量减去它就是另一个区域的学生量了
比较坑的是。。。const ll inf= 0x7fffffff3fffffff;
wa了好几次才发现是这里啊!

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#define maxn 100010
#define maxe 2000010
using namespace std;
typedef long long ll;
int n;
int ca=1;
ll tree[maxn];
ll sum;
ll d[maxn];
int head[maxe];
int pre[maxn];
ll cnt=0;
const ll inf=0x7fffffff3fffffff;
int m;
ll ans=inf;
const int mod = 1e9+7;
struct Node
{
    int to,next;
}e[maxe];
void add(ll a,ll b)
{
    e[cnt].to=b;
    e[cnt].next=head[a];
    head[a]=cnt++;
}
void init()
{
    memset(tree,0,sizeof(tree));
    memset(head,-1,sizeof(head));
    cnt=0;
    sum=0;
    ans=inf;
}

void getnum(ll x,ll fx)
{
    tree[x]=d[x];
    for(int i=head[x];i!=-1;i=e[i].next)
    {
        int cur=e[i].to;
        if(cur==fx)continue;
        getnum(cur,x);
        tree[x]+=tree[cur];
    }
    ll t=sum-2*tree[x];
    ll dif=t>0?t:(-t);
    if(ans>dif)ans=dif;

}

void solve()
{
    getnum(1,-1);
    printf("Case %d: %I64d\n",ca++,ans);

}
int main()
{
    int  t;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)break;
        init();
        ll a,b;
        for(int i=1;i<=n;i++){scanf("%I64d",&d[i]);sum+=d[i];}
        for(int i=0;i<m;i++)
        {
            scanf("%I64d%I64d",&a,&b);
            add(a,b);
            add(b,a);
        }
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值