POJ 1328 Radar Installation(贪心——最少区间选点覆盖)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 93549 Accepted: 20884
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2
Case 2: 1
Source

Beijing 2002

题意 给你N个点的直角坐标,用半径为d,圆心在x轴的圆包括它们 求最小的圆的个数

做法:根据勾股定理求出每个点在x轴上能被覆盖的范围,求这么多区间最少的点覆盖
1、对这些区间按左端点排序
2、取每次覆盖区间的最右能覆盖到的端点tmp
对下一个区间有三种情况
这里写图片描述

1 2情况都可覆盖到,但是1的情况是右端点缩小了,就要把tmp赋值为b
3的情况是这个区间和当前的覆盖区间无交集,就要开一个新的区间了

PS : 一开始tmp声明成了Int死都过不了 gg

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <stack>
#include <vector>
#define maxn 10010
#define maxe 100010
typedef long long ll;
using namespace std;
const double eps=1e-5;
const int inf=0x3f3f3f3f3f;
struct Node
{
    double x,y;
    double a,b;
    bool init(double d)
    {
        double t=d*d-y*y;
        if(t<0)return false;
        double c=sqrt(t);
        a=x-c;
        b=x+c;
        return true;
    }
}node[maxn];
bool cmp(Node s,Node r)
{
    return s.a<r.a;
}
int main()
{
    int n;
    double d;
    int cas=1;
    //freopen("in.txt","r",stdin);
    int flag=0;
    while(scanf("%d%lf",&n,&d)!=EOF)
    {
        if(n==0&&d==0)break;
        flag=0;

        if(d<0)flag=1;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&node[i].x,&node[i].y);
            if(!node[i].init(d))flag=1;
            else if(abs(node[i].y)>d)flag=1;
        }
        printf("Case %d: ",cas++);
        if(flag){puts("-1");continue;}
        sort(node,node+n,cmp);
        double tmp = node[0].b;
        int ans=1;
        for(int i=1;i<n;i++)
        {
            if(tmp>node[i].b)tmp=node[i].b;
            else if(tmp<node[i].a)
            {
                ans++;
                tmp=node[i].b;
            }
        }
        printf("%d\n",ans);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值