Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

 

老王想安排自己家的牛做家务,要求1-T时间内至少有一头牛在工作,(1-3, 4-T)是允许的,但是必须以1开始,以T结尾,能安排的话输出使用牛的最小总数,不能安排输出-1;

思路:按开始时间升序排列,找到可以覆盖当前起点的最远距离,更新起点,继续找

时间复杂度为O(n);每只牛最多遍历两遍

#include<iostream>
#include<cstdio>
#include<fstream>
#include<queue>
#include<vector>
#include<cstring>
#include<algorithm>
#define MAX 26000
#define INF 10000000

using namespace std;

//按照结束时间降序排列
//贪心选择就行

struct cow{
	int start, end;
};

bool cmp(cow x, cow y){
	return x.start < y.start;
}

int main(){
	ifstream in ("D:\\钢铁程序员\\程序数据\\025奶牛做家务.txt");
	if(!in){
		cout << "ERROR" << endl ;
		return 0;
	}
	int N, T;
	cow c[MAX];
	int ans;
	int s;
	int maxd; 
	in >> N >> T;
	for(int i=0; i<N; i++){
		in >> c[i].start >> c[i].end;
	}
	sort(c, c+N, cmp);
	
	s = 0;
	maxd = 0;
	ans = 0;
	int pos = 0;
	while(maxd < T){
		s = maxd + 1;
		//遍历如果能覆盖start,更新最远距离maxd 
		for(int i=pos; i<N; i++){
			if(s >= c[i].start){
				maxd = max(c[i].end, maxd);
			}
			//如果不能覆盖,以maxd为start准备换牛 
			else{
				pos = i;
				break;
			}
		}
		//在这次循环中没有找到可以接班的牛,失败 
		if(s > maxd){
			ans = -1;
			break;
		}
		//找到了, ans ++ 
		else
			ans ++ ;
	}
	cout << ans << endl;
	in.close();
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值