【算法】Raid-分治法

Raid

总时间限制: 1000ms 内存限制: 65536kB
描述
After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union’s attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

输入
The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 1000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.

输出
For each test case output the minimum distance with precision of three decimal placed in a separate line.

样例输入
2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
样例输出
1.414
0.000

#include <cmath>
#include <cstdio>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <algorithm>
#define MAX 200010
#define INF 1e15
using namespace std;
struct Point{
	double x,y;
	bool p;
	bool operator <(const Point &a)const {
		return x < a.x;
	}
	void Read(bool _) {
		scanf("%lf%lf",&x,&y);p = _;
	}
}point[MAX],L[MAX],R[MAX];
int points;
inline double Calc(const Point &p1,const Point &p2){
	return sqrt((p1.x - p2.x) * (p1.x - p2.x) + (p1.y - p2.y) * (p1.y - p2.y));
}
bool cmp(const Point &p1,const Point &p2){
	return p1.y < p2.y;
}
double Solve(int l,int r){
	double re = INF;
	if(r - l <= 2) {
		for(int i = l; i <= r; ++i)
			for(int j = i + 1; j <= r; ++j)
				if(point[i].p != point[j].p)
					re = min(re,Calc(point[i],point[j]));
		return re;
	}
	int mid = (l + r) >> 1;
	re = min(re,Solve(l,mid));
	re = min(re,Solve(mid + 1,r));
	double x = (point[mid].x + point[mid + 1].x) / 2.0;
	int pl = mid,pr = mid + 1;
	int ltop = 0,rtop = 0;
	while(x - point[pl].x <= re && pl >= l)
		L[++ltop] = point[pl--];
	while(point[pr].x - x <= re && pr <= r)
		R[++rtop] = point[pr++];sort(L + 1,L + ltop + 1,cmp);
	sort(R + 1,R + rtop + 1,cmp);
	int start = 1;
	for(int i = 1; i <= ltop; ++i) {
		while(L[i].y - R[start].y > re)
			++start;
		for(int j = start; R[j].y - L[i].y < re && j <= rtop; ++j)
			if(L[i].p != R[j].p)
				re = min(re,Calc(L[i],R[j]));
	}
	return re;
}
int main(){
	int T;
	for(cin >> T; T--;) {
		scanf("%d",&points);
		for(int i = 1; i <= points; ++i)
			point[i].Read(true);
		for(int i = points + 1; i <= (points << 1); ++i)
			point[i].Read(false);
		points <<= 1;
		sort(point + 1,point + points + 1);
		printf("%.3f\n",Solve(1,points));
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值