[UVa10003]切木棍

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of workrequires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. Forexample, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a priceof 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positivenumber l that represents the length of the stick to be cut. You can assume l < 1000. The next line willcontain the number n (n < 50) of cuts to be made.The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cutshave to be done, given in strictly increasing order.An input case with l = 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost ofcutting the given stick. Format the output as shown below.

Sample Input

100

3

25 50 75

10

4

4 5 7 8

0

Sample Output

The minimum cutting is 200.

The minimum cutting is 22.


题意:把一根木棍按给定的n个点切下去,每次切的花费为切的那段木棍的长度,求最小花费。


题解:处理出每一段的长度,问题就转化为了石子合并问题。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int N=1010;
int n, l, L[N];
int dp[N][N], s[N][N];

int main() {
	while( ~scanf( "%d", &l ) ) {
		if( !l ) break;
		memset( L, 0, sizeof L );
		scanf( "%d", &n ); 
		for( int i=2; i<=n+1; i++ ) {
			scanf( "%d", &L[i] );
			L[i-1]=L[i]-L[i-1];
		}
		n++;
		L[n]=l-L[n];
		for( int i=1; i<=n; i++ )
			for( int j=i; j<=n; j++ )
				s[i][j]=s[i][j-1]+L[j];
		
		for( int len=2; len<=n; len++ )
			for( int i=1; i<=n; i++ ) {
				int j=i+len-1;
				dp[i][j]=INF;
				for(int k=i;k<j;k++)
					dp[i][j]=min( dp[i][j],dp[i][k]+dp[k+1][j]+s[i][j] );
			}
		printf( "The minimum cutting is %d.\n", dp[1][n] );
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值