PAT (Advanced Level) 1121. Damn Single (25)

1121. Damn Single (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888

这道题目真的提交了好多次。。。首先是忘记输出个数了,然后又是输出的时候没有写成%05d的形式~

最后是一直有一个测试点过不去,蓝后我又厚着脸皮去问了大神~因为我想的是用vector来装载一开始需要判断的所有人,然后对这个vector遍历,如果遇到couple就把他们两个删除掉,留下都是单身狗啦~

想的是简单的,但是实际情况要注意两个地方,第一就是虽然刚开始记录了cp1的坐标,然后遇到cp2再读取cp1的坐标是错误的行为,因为如果在这对情侣cp2还没被遍历到的时候,他们中间有情侣被遍历到,且被删除,他们两个的坐标全部会受到影响~所以在删除之前,保险的做法是获取他们两个的坐标值,用distance()和find()

第二点就是大神指出的,在for循环里面删除节点,那么i<v.size()肯定是动态变化的,所以判断条件都动态变化了,那么i值不能勇往直前的一直++啊,所以在每次删除两个节点后,我们要修改i值使得它正好指向cp1被删除的前一个位置(因为等会还要++一次)

#include<cstdio>
#include<queue>
#include<vector>
#include<map>
#include<algorithm>

using namespace std;

const int maxn = 10000000;
map<int, int> mm;
vector<int> v;
int position;
bool vis[maxn] = { false };
bool cp[maxn] = { false };


int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		int a, b;
		scanf("%d%d", &a, &b);
		mm[a] = b;
		mm[b] = a;
		cp[a] = true;
		cp[b] = true;
	}

	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		int temp;
		scanf("%d", &temp);
		v.push_back(temp);
	}

	for (int i = 0; i < v.size(); i++) {
		if (cp[v[i]]) {
			if (vis[mm[v[i]]] == true) {
				vis[v[i]] = true;
				int temp = v[i];

				position = distance(v.begin(), find(v.begin(), v.end(), v[i]));
				v.erase(v.begin() + position);

				position = distance(v.begin(), find(v.begin(), v.end(), mm[temp]));
				v.erase(v.begin() + position);
				i = position - 1;
			}
			else {
				vis[v[i]] = true;
			}
		}
	}

	sort(v.begin(), v.end());
	printf("%d\n", v.size());
	for (int i = 0; i < v.size(); i++) {
		if (i != v.size() - 1) {
			printf("%05d ", v[i]);
		}
		else {
			printf("%05d\n", v[i]);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值