1121 Damn Single -PAT甲级

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

利用map来一一匹配,利用两个set集合一个存储参加party的人员,另一个存储落单的人,自动排序

注意:题目中要求不能输出多余的空行,可能落单的人员为0,不需要输出空行,注意在最后的输出换行应舍去,不然会有一个测试点无法通过

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
map<int,int>mp;
set<int>st;//参加party的人 
set<int>res;//结果集的人 
int n,m;
int main(){
	cin>>n;
	for(int i=1;i<=n;i++){
		int x,y;
		cin>>x>>y;
		mp[x]=y;
		mp[y]=x;
	} 
	cin>>m;
	for(int i=1;i<=m;i++){
		int x;
		cin>>x;
		st.insert(x);
	}
	for(auto i=st.begin();i!=st.end();i++){
		if(st.find(mp[*i])==st.end())
			res.insert(*i);
	}
	cout<<res.size()<<endl;
	int flag=0;
	for(auto i=res.begin();i!=res.end();i++){
		if(flag) cout<<" ";
		flag=1;
		printf("%05d",*i);		
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值