HDU1312 BFS JAVA

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

代码:

import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class HDU1312 {
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
	boolean[][] G,marked;
	Queue<Integer> Ri=new LinkedList<Integer>();
	Queue<Integer> Rj=new LinkedList<Integer>();
	int fi=0,fj=0;
	int[][] dir= {{-1,0},{1,0},{0,-1},{0,1}};
	Scanner in=new Scanner(System.in);
	while(in.hasNext()) {
		int W=in.nextInt(),H=in.nextInt();
		if(W==0 && H==0) {
			return;	
		}
		String blank=in.nextLine();
		G=new boolean[H][W];
		marked=new boolean[H][W];
		for(int i=0;i<H;i++) {
			String str=in.nextLine().trim();//in.nextLine();
			for(int j=0;j<W;j++) {
				if(str.charAt(j)=='#')
					G[i][j]=false;
				else {
					G[i][j]=true;
					if(str.charAt(j)=='@') {fi=i;fj=j;}
				}
			}
		}
		int count=0;
		marked[fi][fj]=true;
		Ri.add(fi);Rj.add(fj);
		while(!Ri.isEmpty()) {
			int i=Ri.poll(),j=Rj.poll();
			
			for(int a[]:dir) {
				if((i+a[0]>-1) && (i+a[0]<H) && (j+a[1]>-1) && (j+a[1]<W)) {
					if(G[i+a[0]][j+a[1]]) {
						if(!marked[i+a[0]][j+a[1]]) {//忘掉了marked[]
							marked[i+a[0]][j+a[1]]=true;
							Ri.add(i+a[0]);
							Rj.add(j+a[1]);
							count++;
							}
						}
							
					}	
				}	
			
		}
		System.out.println(count+1);
	}
	
}

}

反馈

1.nextInt之后用nextLine无法读取输入
在in.nextInt()之后,起初没有String blank=in.nextLine();,会弹出如下错误,经查询后发现,原因是nextInt()再扫描到空白符的时候,将空白符之前的数据取掉,留下空白符在缓冲区中,in.nextLine()会接受这个空白符,经过Debug,发现如果没有String blank=in.nextLine();str为空,却调用str.charAt(0),自然会弹出错误。
java中Scanner类nextInt之后用nextLine无法读取输入
在这里插入图片描述
2.忘了使用marked标识是否检查过该砖块

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值