HDU1009 FatMouse' Trade(贪心)

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains Jii pounds of JavaBeans and requires Fii pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get Jii* a% pounds of JavaBeans if he pays Fii* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers Jii and Fii respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500

题意:这只胖老鼠准备了m磅的猫娘- -准备诱惑猫以换取机会取得这个猫所在格子的最喜欢的食物———java豆!有n个格子,每个格子有j磅的java豆同时需要花费f磅猫娘- -但是他也可以只付出部分猫娘换取部分java豆~求这只胖老鼠最多可以吃到多少java豆

解题思路:(鄙人才疏学浅,正在努力学习贪心算法和动态规划的区别)
此处我们引入一个性价比的概念,设为percent吧percent等于j/f。计算每个格子的性价比,按性价比从高到低排序。这只胖老鼠肯定会尽量把猫娘都花费在性价比高的格子里啦~

AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;

struct Node
{
    int j,f;
    double percent;
} Q[3001];

bool cmp(Node a,Node b)
{
    return a.percent>b.percent;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        if(n==-1||m==-1) break;
        int i;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&Q[i].j,&Q[i].f);
            Q[i].percent=(double)Q[i].j/Q[i].f;
        }
        sort(Q,Q+n,cmp);
        double sum=0;
        for(i=0;i<n;i++)
        {
            if(m>Q[i].f)
            {
                sum+=Q[i].j;
                m-=Q[i].f;
            }
            else
            {
                sum+=Q[i].percent*m;
                m=0;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值