HDU1009 - FatMouse' Trade - 贪心

1.题目描述:

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73381    Accepted Submission(s): 25200


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining
 

2.题意概述:

鼠准备了M磅猫食,准备拿这些猫食跟猫交换自己喜欢的食物。有N个房间,每个房间里面都有食物。你可以得到J[i]但你需要付出F[i]的猫食。要你计算你有M磅猫食可以获得最多食物的重量。

3.解题思路:

每件事物定义性价比为J[i]/F[i],那么直接用结构体对每个实物预处理一下,按性价比排序,贪心地选取性价比高的食物即可。

4.AC代码:

#include <stdio.h>
#include <algorithm>
#define maxn 1010
using namespace std;
struct node
{
	double j, f, r;
	friend bool operator< (node a, node b)
	{
		return a.r > b.r;
	}
}a[maxn];
int main()
{
	int N;
	double M;
	while (scanf("%lf%d", &M, &N) != EOF && M != -1 && N != -1)
	{
		for (int i = 0; i < N; i++)
		{
			scanf("%lf%lf", &a[i].j, &a[i].f);
			a[i].r = (double)a[i].j / a[i].f;
		}
		sort(a, a + N);
		double ans = 0;
		for (int i = 0; i < N; i++)
		{
			if (M >= a[i].f)
			{
				ans += a[i].j;
				M -= a[i].f;
			}
			else
			{
				ans += (a[i].j / a[i].f)*M;
				break;
			}
		}
		printf("%.3lf\n", ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值