HDU-1009 FatMouse' Trade

                                                    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1009

                                                                              FatMouse' Trade

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

题意:

胖老鼠有m磅猫粮,要准备和猫换食物,有n个房间,每个房间他可以用f磅猫粮换j磅食物,问用完全部猫粮最多可换多少食物。

解题思路:先算出各个房间的兑换比率,按比率从大到小排序,再一次累加计算。

代码:

#include <stdio.h>
#include <string.h>

int main()
{
	int i,k;
	double m,n,j1,f1,s,c;
	double j[1010],f[1010],a[1010];
	while(scanf("%lf%lf",&m,&n)!=EOF)
	{
		s=0;c=0;
		if(m==-1&&n==-1)
			break;
		for(i=1;i<=n;i++)
		{
			scanf("%lf%lf",&j[i],&f[i]);
			s+=j[i];
			c+=f[i];
		}	
		if(m>=c)
		{
			printf("%.3f\n",s);
			continue;
		}
		for(i=1;i<n;i++)
			for(k=i+1;k<=n;k++)
			{
				if(j[k]/f[k]>j[i]/f[i])
				{
					j1=j[k];f1=f[k];
					j[k]=j[i];f[k]=f[i];
					j[i]=j1;f[i]=f1;
				}
			}
		//for(i=1;i<=n;i++)
		//	printf("%f %f\n",j[i],f[i]);
		s=0;c=0;
		for(i=1;i<=n;i++)
		{
			c+=f[i];
			if(c>m){
				c=c-f[i];
				break;
			}
			s+=j[i];		
		}
		s+=j[i]*(m-c)/f[i];
		printf("%.3f\n",s);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值