二叉排序树:HUD3999-The order of a Tree(二叉排序树字典序输出)

The order of a Tree

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2070 Accepted Submission(s): 1097

Problem Description

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1. insert a key k to a empty tree, then the tree become a tree with
only one node;
2. insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4


解题心得:
  1. 题意就是给你一串数,先生成一个二叉排序树,然后按照字典序输出就可以了。没有什么难点,只是在按照字典序输出的时候注意递归输出方式就可以了。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+100;
int n,index;
struct node
{
    int num;
    node *lchild,*rchild;
} tree[maxn];

node* newnode(int num)
{
    tree[index].num = num;
    tree[index].lchild = NULL;
    tree[index].rchild = NULL;
    return &tree[index++];
}

void insertBST(node*& root,int num)
{
    if(root == NULL)
    {
        root = newnode(num);
        return ;
    }
    else if(root->num > num)
        insertBST(root->lchild,num);
    else
        insertBST(root->rchild,num);
}

void buildtree(node*& root)
{
    root = NULL;
    int num;
    for(int i=1; i<=n; i++)
    {
        scanf("%d",&num);
        insertBST(root,num);
    }
}


void print(node*& root,int num)
{
    if(root == NULL)
        return ;
    if(num == 2)
        printf(" ");
    printf("%d",root->num);//搜到一个输入一个
    print(root->lchild,2);//先向左方开始找
    print(root->rchild,2);
}

int main()
{
    while(scanf("%d",&n) != EOF)
    {
        node *p;
        index = 0;
        buildtree(p);//先构建二叉树
        print(p,1);//然后输出
        printf("\n");
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值